当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : install vim-full 出了一些问题
帖子发表于 : 2009-10-14 8:54 
头像

注册: 2009-09-08 14:42
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
请高手看看,这个问题怎么解决...
想设置 vim 里 tab 键的宽度 ,找了下没有.vimrc这个文件,GOOGLE下需安装vim-full

代码:
sudo apt-get install vim-full

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
vim-full 已经是最新的版本了。
下列软件包是自动安装的并且现在不再被使用了:
wine-gecko libwxgtk2.8-0 ttf-liberation libwxbase2.8-0 cabextract
python-wxversion imagemagick-doc imagemagick python-wxgtk2.8 winbind
使用'apt-get autoremove'来删除它们
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 5 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
关键是这里
正在设置 linux-image-2.6.28-15-generic (2.6.28-15.52) ...
Running depmod.
Failed to run depmod
dpkg:处理 linux-image-2.6.28-15-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.28-15-generic 的配置工作不能继续:
linux-restricted-modules-2.6.28-15-generic 依赖于 linux-image-2.6.28-15-generic;然而:
软件包 linux-image-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.28-15-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-image-generic 的配置工作不能继续:
linux-image-generic 依赖于 linux-image-2.6.28-15-generic;然而:
软件包 linux-image-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-image-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-generic 的配置工作不能继续:
linux-restricted-modules-generic 依赖于 linux-restricted-No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
modules-2.6.28-15-generic;然而:
软件包 linux-restricted-modules-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-generic 的配置工作不能继续:
linux-generic 依赖于 linux-image-generic (= 2.6.28.15.20);然而:
软件包 linux-image-generic 还没有被配置。
linux-generic 依赖于 linux-restricted-modules-generic (= 2.6.28.15.20);然而:
软件包 linux-restricted-modules-generic 还没有被配置。
dpkg:处理 linux-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-image-2.6.28-15-generic
linux-restricted-modules-2.6.28-15-generic
linux-image-generic
linux-restricted-modules-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

之后又运行
代码:
sudo dpkg --configure -a

正在设置 linux-image-2.6.28-15-generic (2.6.28-15.52) ...
Running depmod.
Failed to run depmod
dpkg:处理 linux-image-2.6.28-15-generic (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 linux-restricted-modules-2.6.28-15-generic 的配置工作不能继续:
linux-restricted-modules-2.6.28-15-generic 依赖于 linux-image-2.6.28-15-generic;然而:
软件包 linux-image-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-2.6.28-15-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-image-generic 的配置工作不能继续:
linux-image-generic 依赖于 linux-image-2.6.28-15-generic;然而:
软件包 linux-image-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-image-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-restricted-modules-generic 的配置工作不能继续:
linux-restricted-modules-generic 依赖于 linux-restricted-modules-2.6.28-15-generic;然而:
软件包 linux-restricted-modules-2.6.28-15-generic 还没有被配置。
dpkg:处理 linux-restricted-modules-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 linux-generic 的配置工作不能继续:
linux-generic 依赖于 linux-image-generic (= 2.6.28.15.20);然而:
软件包 linux-image-generic 还没有被配置。
linux-generic 依赖于 linux-restricted-modules-generic (= 2.6.28.15.20);然而:
软件包 linux-restricted-modules-generic 还没有被配置。
dpkg:处理 linux-generic (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
linux-image-2.6.28-15-generic
linux-restricted-modules-2.6.28-15-generic
linux-image-generic
linux-restricted-modules-generic
linux-generic


_________________
初学菜鸟...
Contact: Q.139010301 MAIL:eholch@sina.com
Man proposes, God disposes!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: install vim-full 出了一些问题
帖子发表于 : 2009-10-14 13:13 
头像

注册: 2009-04-11 23:46
帖子: 4029
系统: Arch Linux
送出感谢: 11
接收感谢: 110
这个和 Vim 有什么关系? .vimrc 文件没有就自己建一个呗。所有配置文件都这样,如果没有就自己建。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
3 楼 
 文章标题 : Re: install vim-full 出了一些问题
帖子发表于 : 2009-10-15 6:21 
头像

注册: 2009-09-08 14:42
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
在处理时有错误发生:
linux-image-2.6.28-15-generic
linux-restricted-modules-2.6.28-15-generic
linux-image-generic
linux-restricted-modules-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
先做备份
代码:
cd /var/lib/dpkg

代码:
sudo mv info info.bak

创建一个新的
代码:
sudo mkdir info

重新安装
代码:
sudo apt-get --reinstall install linux-image-2.6.28-15-generic linux-restricted-modules-2.6.28-15-generic linux-image-generic linux-restricted-modules-generic linux-generi


_________________
初学菜鸟...
Contact: Q.139010301 MAIL:eholch@sina.com
Man proposes, God disposes!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译