当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 0:09 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
请问大家:
1-----ubuntu 8.04上的vim还能升级到vim 7.2吗?我的现在是vim 7.1
2-----我在虚拟机上编译安装了vim 7.2,中间没出现错误,终端下:gvim,却提示gvim没有安装,让我用sudo apt-get install来安装
3-----我试了一下新安装好的vim,怎么在“: ”模式下,按上下箭头键,没有出现刚刚输入的上次的命令,还要修改vimrc吗?
请高手指教!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 1:20 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
hugUbuntu 写道:
请问大家:
1-----ubuntu 8.04上的vim还能升级到vim 7.2吗?我的现在是vim 7.1
2-----我在虚拟机上编译安装了vim 7.2,中间没出现错误,终端下:gvim,却提示gvim没有安装,让我用sudo apt-get install来安装
3-----我试了一下新安装好的vim,怎么在“: ”模式下,按上下箭头键,没有出现刚刚输入的上次的命令,还要修改vimrc吗?
请高手指教!

1-----自己编译吧
2,3---:version


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 13:02 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
hugUbuntu 写道:
请问大家:
1-----ubuntu 8.04上的vim还能升级到vim 7.2吗?我的现在是vim 7.1
2-----我在虚拟机上编译安装了vim 7.2,中间没出现错误,终端下:gvim,却提示gvim没有安装,让我用sudo apt-get install来安装
3-----我试了一下新安装好的vim,怎么在“: ”模式下,按上下箭头键,没有出现刚刚输入的上次的命令,还要修改vimrc吗?
请高手指教!

1-----自己编译吧
2,3---:version

你意思是版本问题?
我编译安装好了vim 7.2,只能运行vim,但没有gvim,在makefile中我已经把CONF_OPT_GUI = --enable-gui=gtk2 的注释去掉,但就是系统说没有gvim,
然后我又重新编译,加入了./configure with-x --enable-gui=gtk2,安装完后,试了一下,还是没有阿!
高手可否详解一下?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 13:40 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
hugUbuntu 写道:
你意思是版本问题?
我编译安装好了vim 7.2,只能运行vim,但没有gvim,在makefile中我已经把CONF_OPT_GUI = --enable-gui=gtk2 的注释去掉,但就是系统说没有gvim,
然后我又重新编译,加入了./configure with-x --enable-gui=gtk2,安装完后,试了一下,还是没有阿!
高手可否详解一下?

我是让你贴下:version命令的结果 :em20


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 22:37 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
hugUbuntu 写道:
你意思是版本问题?
我编译安装好了vim 7.2,只能运行vim,但没有gvim,在makefile中我已经把CONF_OPT_GUI = --enable-gui=gtk2 的注释去掉,但就是系统说没有gvim,
然后我又重新编译,加入了./configure with-x --enable-gui=gtk2,安装完后,试了一下,还是没有阿!
高手可否详解一下?

我是让你贴下:version命令的结果 :em20

呵呵,不好意思,我理解错了,我已经弄好了,编译安装前要执行这个:sudo apt-get build-dep vim-gtk

但不知为何,我的vim 7.2不读取/etc/vimrc,只能读取~/.vimrc,这个问题该如何解决阿! (我原来源里安装的vim已经删除干净了)


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-18 22:58 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
我的有个/etc/vim,在$VIM/有指向此的链接。也就是说,Vim本来就是不读那个的。想要它去读的话,可以用链接或者在启动脚本里写
代码:
so /etc/vimrc


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 1:02 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
我的有个/etc/vim,在$VIM/有指向此的链接。也就是说,Vim本来就是不读那个的。想要它去读的话,可以用链接或者在启动脚本里写
代码:
so /etc/vimrc

明白了,还有一个小问题,我退出vim又出现了终端乱码,这在用apt-get install vim-full安装vim也出现过,当时用
sudo update-alternatives --config vim 解决了,现在我把系统上原来的vim全删了,重新编译安装了vim 7.2,为何还出现这种情况?
第一:我在vim可以写中文无乱码
第二:这种情况只出现在路径下含中文时
第三:在终端标题加2边的空格,也不行

这该如何解决?多谢!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 13:41 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
不太明白你的具体情况。你截个图看看吧。也看看以下命令的输出结果:
代码:
:set enc

看一下它的值和终端的编码是否一致。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 17:43 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
不太明白你的具体情况。你截个图看看吧。也看看以下命令的输出结果:
代码:
:set enc

看一下它的值和终端的编码是否一致。

我在.vimrc中加入了
set encoding=utf-8
运行:
附件:
screenshot_004.png
screenshot_004.png [ 1.01 KiB | 被浏览 2021 次 ]

得到:
附件:
screenshot_005.png
screenshot_005.png [ 1.89 KiB | 被浏览 2021 次 ]

和终端编码一致
退出vim:
附件:
screenshot_006.png
screenshot_006.png [ 13.3 KiB | 被浏览 2021 次 ]


请帮我看看!多谢!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 19:33 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
原来是这样。这个我也遇到过,没太在意。试了几次,没有再出现那种情况了。好像也不影响使用啊。
你可以尝试把消息重定向,然后研究一下那段文字的编码和内容。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 22:37 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
原来是这样。这个我也遇到过,没太在意。试了几次,没有再出现那种情况了。好像也不影响使用啊。
你可以尝试把消息重定向,然后研究一下那段文字的编码和内容。

我在乱码的终端上输入$ ls > xx.txt
查看xx.txt,里面的显示包括中文完全正常,而字符编码依然是utf-8,这就奇怪了,vim是utf-8.终端上还是utf-8,为何还有乱码?好郁闷


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-19 23:05 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
hugUbuntu 写道:
lilydjwg 写道:
你可以尝试把消息重定向,然后研究一下那段文字的编码和内容。

我在乱码的终端上输入$ ls > xx.txt
查看xx.txt,里面的显示包括中文完全正常,而字符编码依然是utf-8,这就奇怪了,vim是utf-8.终端上还是utf-8,为何还有乱码?好郁闷

我指的是Vim的乱码消息。可能Vim的乱码消息不是UTF-8的。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-20 0:08 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
hugUbuntu 写道:
lilydjwg 写道:
你可以尝试把消息重定向,然后研究一下那段文字的编码和内容。

我在乱码的终端上输入$ ls > xx.txt
查看xx.txt,里面的显示包括中文完全正常,而字符编码依然是utf-8,这就奇怪了,vim是utf-8.终端上还是utf-8,为何还有乱码?好郁闷

我指的是Vim的乱码消息。可能Vim的乱码消息不是UTF-8的。

不太明白,我第一次退出vim,终端是乱码,立即在进入vim,此时vim里面是乱码,再退出vim,此时终端无乱码,高手能否详细指点一下,你的vim是编译安装的吗?能告诉我--你的方法吗?


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-20 12:14 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
这样啊。vim > tmpfile 然后退出Vim看下 tmpfile 里面有什么吧。
感觉你这问题很诡异。我的vim是从源里安装的。
刚刚编译了一次,运行未发现乱码。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 关于vim升级和编译安装的问题
帖子发表于 : 2009-10-20 23:14 

注册: 2009-06-10 9:51
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
lilydjwg 写道:
这样啊。vim > tmpfile 然后退出Vim看下 tmpfile 里面有什么吧。
感觉你这问题很诡异。我的vim是从源里安装的。
刚刚编译了一次,运行未发现乱码。

我试了一下vim > tmpfile,出现以下情况:
附件:
screenshot_007.png
screenshot_007.png [ 4.66 KiB | 被浏览 1998 次 ]

vim无法打开,于是强行关掉vim,用gedit 打开 tmpfile,查看编码还是utf-8,不过其中有一部分乱码,我看不懂,信息如下(不知为何,我上传不了此文件):

[?1000h[?1049h[?1h=[?12;25h[?12l[?25h[?25l 1 

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ VIM - Vi IMproved版本 7.2维护人 Bram Moolenaar 等Vim 是可自由分发的开放源代码软件赞助 Vim 的开发!输入 :help sponsor<Enter> 查看说明 输入 :q<Enter> 退出 输入 :help<Enter> 或 <F1> 查看在线帮助 输入 :help version7<Enter> 查看版本信息 ]2;[未命名] - VIM]1;[未命名][?12l[?25h[?25l^M  [?12l[?25h[?25lE78: 未知的标记[?12l[?25h[?25l-- 插入 --  2 me/jianshen/桌面/tmpfile'          ]2;[未命名] + - VIM]1;[未命名][?12l[?25h[?25l

 3 [?12l[?25h[?25l

 4 [?12l[?25h[?25l[?12l[?25h[?25l输入 :quit<Enter> 退出 Vim[?12l[?25h[?1l>[?1049lVim: 拦截到致命信号(deadly signal) TERM

Vim: 正在保留文件……

Vim: 结束。

]2;jianshen@jianshen-desktop: ~/$(AW@Cf]1;jianshen@jianshen-desktop: ~/$(AW@Cf


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译