[问题]编译安装vim7,怎么也装不上gui

Vim、Emacs配置和使用
回复
xell
帖子: 174
注册时间: 2006-08-26 19:52
送出感谢: 0
接收感谢: 0

[问题]编译安装vim7,怎么也装不上gui

#1

帖子 xell » 2006-09-10 11:52

我在安装的时候加上了--enable-gui=auto,不行,后来我试了=gtk2, =gnome2, =gtk, =gnome,都不行,这是为什么?我装上了vim-gtk和vim-gnome包了
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-09-10 13:06

本区有个vim7编译指南的.按照那个,应该可以成功.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
poet
帖子: 2841
注册时间: 2006-09-11 22:47
送出感谢: 0
接收感谢: 4 次

#3

帖子 poet » 2006-09-11 23:01

今天刚编译过,vim70,GTK版本。我的自己摸索的建议:

sudo aptitude install xorg-dev libgtk2.0-dev build-essential

应该就差不多了。

./configure 先测试一下能不能检测出 X 。

刚开始装了 libgtk2.0-dev 之后总是不能检测出 X,结果后来到主站上看到有人 install xorg-dev ,然后就搞定了!
回复

回到 “Vim和Emacs”