当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : emacs23启动后,狂占cpu!!
帖子发表于 : 2006-09-13 9:13 

注册: 2006-01-19 15:17
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
大家有没有这个现象??

发现是ecb这个插件的问题, 启动load ecb后,打开一个文件,cpu占用90%以上,而且频率也达到最高。
而不装载ecb就没有这个问题。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-09-13 14:00 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
我这里 semantics 的某个功能也是这样,还会导致 emacs 死掉。好像就是自动弹出补全菜单的那个功能,不过我不怎么编程,也就没有使用这个插件了.


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-09-14 10:29 

注册: 2005-12-20 21:26
帖子: 122
地址: UESTC
送出感谢: 0 次
接收感谢: 0 次
用了那么久,我的都没有出现你们说的那种现象哈。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-09-14 13:02 

注册: 2006-02-23 12:42
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我之前也碰到过这个问题,在.emacs 中加入这个

代码:
(setq semantic-idle-scheduler-idle-time 1000000)


最后的数值我是随便设的,反正设成足够大,让它不会发生,具体的作用在这里查到
http://blog.gmane.org/gmane.emacs.jdee/month=20050301

引用:
Re[1]: Update Tag Table messages
From: Eric M. Ludlam <eric <at> siege-engine.com>
Subject: Re[1]: Update Tag Table messages
Newsgroups: gmane.emacs.jdee
Date: 2005-03-02 20:03:39 GMT

>>> Joseph Shraibman <jks <at> selectacast.net> seems to think that:
>I am being driven mad by these "Update Tag Table" messages that semantic
>is giving me. Whenever this happens emacs freezes on me for a few
>seconds. How can I turn this off?
>

You can either increase the idle time via
semantic-idle-scheduler-idle-time or you can disable
global-semantic-idle-scheduler-mode.

The advantage of the idle scheduler is that it provides tag summaries
and some completion features. The disadvantage is the amount of time
it may take to parse a file. If you don't use those, you can postpone
tag updates till you request some action from semantic via some other
mechanism.

It is supposed to be possible to interrupt the incremental parsing
mechanism by just pressing a key. It is unclear to me why this would
not work for you. There are atomic operations that it doesn't work
in, but I thought those were all pretty short.

Eric


页首
 用户资料  
 
5 楼 
 文章标题 : Re: emacs23启动后,狂占cpu!!
帖子发表于 : 2009-05-06 10:22 

注册: 2008-10-15 10:49
帖子: 583
地址: CS
送出感谢: 0 次
接收感谢: 0 次
网上大多方法为
(setq semantic-idle-scheduler-idle-time 432000)
可能年代久远,在我的机器上就是不管用
照楼上的
设置成1000000,貌似稍微缓解了一下,不过N分钟后问题依旧,无法操作,光标呆滞。按下,C+G后才恢复
哪位解决过此类问题啊?
谢谢


_________________
代码:
 _____________
< 呜呜buntu >
 -------------
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||


页首
 用户资料  
 
6 楼 
 文章标题 : Re: emacs23启动后,狂占cpu!!
帖子发表于 : 2009-05-06 13:52 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
cedet 早就修复了这个问题了,下载新的回来就可以了。


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
7 楼 
 文章标题 : Re: emacs23启动后,狂占cpu!!
帖子发表于 : 2009-05-06 14:35 

注册: 2008-10-15 10:49
帖子: 583
地址: CS
送出感谢: 0 次
接收感谢: 0 次
原来早些时候ecb make的报错被我忽略,后来又忘了,改了一下Makefile ,搞定:em20

Thanks all the same!
:em11


_________________
代码:
 _____________
< 呜呜buntu >
 -------------
        \   ^__^
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译