[求助]emacs 运行的shell,出现奇怪字符

Vim、Emacs配置和使用
回复
saga_song
帖子: 7
注册时间: 2009-11-24 23:08
送出感谢: 0
接收感谢: 0

[求助]emacs 运行的shell,出现奇怪字符

#1

帖子 saga_song » 2010-03-03 3:03

X window 环境下运行 emacs,

在emacs里面用 M-x shell 后,

ls 显示当前目录内容,会出现如附件所示的奇怪字符,

例如:

^[[01;34mmyPrograme^[[0m

其实这个原来是一个 名叫 myPrograme的文件夹;

如果是单个文件,文件名中含有中文字符的话,也会出现前后的字符和数字
^[[01;34m
^[[0m
Screenshot.png
截图
请大虾帮助解决,谢谢。
头像
IAB
帖子: 99
注册时间: 2009-06-03 20:17
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#2

帖子 IAB » 2010-03-03 7:31

我出现过这个是因为编码问题,都改为utf-8吧
davyzhu
帖子: 109
注册时间: 2009-12-06 21:23
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#3

帖子 davyzhu » 2010-03-03 10:27

或者M-x term
saga_song
帖子: 7
注册时间: 2009-11-24 23:08
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#4

帖子 saga_song » 2010-03-03 10:52

davyzhu 写了:或者M-x term

这个有效!!!
谢谢!
saga_song
帖子: 7
注册时间: 2009-11-24 23:08
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#5

帖子 saga_song » 2010-03-03 10:53

IAB 写了:我出现过这个是因为编码问题,都改为utf-8吧

改了UTF-8,还是不行阿,谢谢哦。
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#6

帖子 mikeandmore » 2010-03-04 7:17

IAB 写了:我出现过这个是因为编码问题,都改为utf-8吧
不是,因为eshell是哑终端。
term才不是
davyzhu
帖子: 109
注册时间: 2009-12-06 21:23
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#7

帖子 davyzhu » 2010-03-04 15:46

mikeandmore 写了:
IAB 写了:我出现过这个是因为编码问题,都改为utf-8吧
不是,因为eshell是哑终端。
term才不是
M-x shell 和M-x eshell不是一回事
头像
mikeandmore
帖子: 109
注册时间: 2005-10-13 18:29
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#8

帖子 mikeandmore » 2010-03-05 3:59

davyzhu 写了:
mikeandmore 写了:
IAB 写了:我出现过这个是因为编码问题,都改为utf-8吧
不是,因为eshell是哑终端。
term才不是
M-x shell 和M-x eshell不是一回事
哦,那这个也是哑的。
redflow
帖子: 264
注册时间: 2007-05-14 23:14
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#9

帖子 redflow » 2010-03-06 22:09

.bashrc 里

alias ls='ls --color=auto -X' # add this line to enabled color in emacs shell mode
KDE!!!
Linux 发行版永远都是在重复造轮子。
Linux 发行版总是把应由开发者关心问题抛给普通用户。
cheeselee
帖子: 353
注册时间: 2008-07-09 0:39
送出感谢: 1 次
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#10

帖子 cheeselee » 2010-03-06 23:27

(ansi-color-for-comint-mode-on)
加入~/.emacs
7号机-----神舟 优雅A460P-i7G D2
CPU: i7-2670QM
RAM: 8G
HD:500G
OS:Fedora 17 x86_64

热衷话题:Package Management\Programming
bo_00
帖子: 24
注册时间: 2010-01-10 15:25
送出感谢: 0
接收感谢: 0

Re: [求助]emacs 运行的shell,出现奇怪字符

#11

帖子 bo_00 » 2010-03-16 9:11

我也是有这个问题。

http://blog.chinaunix.net/u3/98822/showart_2196543.html

参看吧
回复

回到 “Vim和Emacs”