当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-03 3:03 

注册: 2009-11-24 23:08
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
X window 环境下运行 emacs,

在emacs里面用 M-x shell 后,

ls 显示当前目录内容,会出现如附件所示的奇怪字符,

例如:

^[[01;34mmyPrograme^[[0m

其实这个原来是一个 名叫 myPrograme的文件夹;

如果是单个文件,文件名中含有中文字符的话,也会出现前后的字符和数字
^[[01;34m
^[[0m

附件:
文件注释: 截图
Screenshot.png
Screenshot.png [ 18.16 KiB | 被浏览 889 次 ]


请大虾帮助解决,谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-03 7:31 
头像

注册: 2009-06-03 20:17
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
我出现过这个是因为编码问题,都改为utf-8吧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-03 10:27 

注册: 2009-12-06 21:23
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
或者M-x term


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-03 10:52 

注册: 2009-11-24 23:08
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
davyzhu 写道:
或者M-x term



这个有效!!!
谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-03 10:53 

注册: 2009-11-24 23:08
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
IAB 写道:
我出现过这个是因为编码问题,都改为utf-8吧



改了UTF-8,还是不行阿,谢谢哦。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-04 7:17 
头像

注册: 2005-10-13 18:29
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
IAB 写道:
我出现过这个是因为编码问题,都改为utf-8吧

不是,因为eshell是哑终端。
term才不是


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-04 15:46 

注册: 2009-12-06 21:23
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
mikeandmore 写道:
IAB 写道:
我出现过这个是因为编码问题,都改为utf-8吧

不是,因为eshell是哑终端。
term才不是


M-x shell 和M-x eshell不是一回事


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-05 3:59 
头像

注册: 2005-10-13 18:29
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
davyzhu 写道:
mikeandmore 写道:
IAB 写道:
我出现过这个是因为编码问题,都改为utf-8吧

不是,因为eshell是哑终端。
term才不是


M-x shell 和M-x eshell不是一回事

哦,那这个也是哑的。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-06 22:09 

注册: 2007-05-14 23:14
帖子: 264
送出感谢: 0 次
接收感谢: 0 次
.bashrc 里

alias ls='ls --color=auto -X' # add this line to enabled color in emacs shell mode


_________________
KDE!!!
Linux 发行版永远都是在重复造轮子。
Linux 发行版总是把应由开发者关心问题抛给普通用户。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-06 23:27 

注册: 2008-07-09 0:39
帖子: 353
送出感谢: 1
接收感谢: 0 次
(ansi-color-for-comint-mode-on)
加入~/.emacs


_________________
7号机-----神舟 优雅A460P-i7G D2
CPU: i7-2670QM
RAM: 8G
HD:500G
OS:Fedora 17 x86_64

热衷话题:Package Management\Programming


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [求助]emacs 运行的shell,出现奇怪字符
帖子发表于 : 2010-03-16 9:11 

注册: 2010-01-10 15:25
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我也是有这个问题。

http://blog.chinaunix.net/u3/98822/showart_2196543.html

参看吧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译