[问题]vim的奇怪问题

Vim、Emacs配置和使用
回复
xell
帖子: 174
注册时间: 2006-08-26 19:52
送出感谢: 0
接收感谢: 0

[问题]vim的奇怪问题

#1

帖子 xell » 2006-10-04 5:38

我装了vim7.0,后来不知道做了什么操作,总之当时乱七八糟的不知道按了什么,然后再去vim后,发现退格键(backspace)变的很奇怪,虽然也退格也删除了一个字符,但是那个字符不消失。另外上下左右四个键按了之后居然出A、B、C、D。

请问这是为什么?我重新安装了都不行……
luckiest
帖子: 27
注册时间: 2006-09-26 23:31
送出感谢: 0
接收感谢: 0

#2

帖子 luckiest » 2006-10-08 21:38

我昨天写了个长长的程序,刚开始还好好的,后来不小心退出了编辑模式,又不稀里糊涂的按了一些键,过了一会儿再看文件也面目全非,删了一些,移了一些,还替换了一些关键词。。。。。。又花了4个小时才搞定。。。。
shanzhuang
帖子: 18
注册时间: 2006-11-07 20:29
送出感谢: 0
接收感谢: 0

#3

帖子 shanzhuang » 2006-11-09 22:23

我也是 谁知道是怎么回事 ?按方向键竟然出来abcd??
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-11-09 23:13

重装。系统在升级的时候,我也碰到过。

$ as vim|grep ^i
i vim-common - Vi IMproved - Common files
i vim-gtk - Vi IMproved - enhanced vi editor - with GT
i vim-gui-common - Vi IMproved - Common GUI files
i vim-runtime - Vi IMproved - Runtime files
i vim-scripts - plugins for vim, adding bells and whistles
● 鸣学
hschen
帖子: 2
注册时间: 2006-10-19 9:16
送出感谢: 0
接收感谢: 0

#5

帖子 hschen » 2006-11-13 14:02

我也遇到这个问题了,是不是ubuntu 6.10的bug.在6.06版下很好用.而且firefox 也有问题.一访问www.sina.com.cn 或www.xinhua.org 等网站就自动关闭了.
etile
帖子: 17
注册时间: 2005-11-14 22:09
来自: SCAU
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 etile » 2006-11-13 21:56

我也遇到过,好象是装的系统默认装的vim-common,这样的话修改/etc/vim/vimrc也不好使。
解决办法是先装上vim-full,再修改/etc/vim/vimrc
在里面找到:
" Vim5 and later versions support syntax highlighting. Uncommenting the next
" line enables syntax highlighting by default.
" syntax on

把" syntax on前的"去掉即可
mosquito-liu
帖子: 170
注册时间: 2005-09-12 22:17
送出感谢: 0
接收感谢: 0

#7

帖子 mosquito-liu » 2006-12-17 10:15

不知道是VIM的问题还是怎么的,现在也发现VIM都不好用了,以前的一些命令都没有办法使用,不知道是怎么回事?
搞的我现在只能用GEDIT,郁闷!
bismy
帖子: 7
注册时间: 2006-08-06 21:02
送出感谢: 0
接收感谢: 0

#8

帖子 bismy » 2006-12-17 19:05

新版本不知道什么问题,缩进也比以前麻烦。
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#9

帖子 leal » 2006-12-26 12:48

拜托

这些都不是Vim7升级的问题,请给出你们的 .vimrc。

我可以保证:全部都是因为 .vimrc 或其他设置问题。
用心×恒 | 豆瓣 | 门户 | Blog
faircloth
帖子: 29
注册时间: 2006-10-29 19:21
送出感谢: 0
接收感谢: 0

是因为6.10 的VIM没有装全 只装了 VIM-COMMON

#10

帖子 faircloth » 2007-01-01 20:48

如题
头像
ronnieshen
帖子: 16
注册时间: 2006-02-13 17:17
送出感谢: 0
接收感谢: 0

#11

帖子 ronnieshen » 2007-01-06 13:37

我新装ubuntu 6.10的也有这个问题.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#12

帖子 eexpress » 2007-01-06 14:05

都不看我的提示。到。就是要安装那些包。
● 鸣学
回复

回到 “Vim和Emacs”