当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]vim 中语法不能分颜色显示,而且profile中设置过了。 请指教!
帖子发表于 : 2006-10-31 18:19 

注册: 2006-09-30 22:54
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
用vim编辑c程序时,语法不能分颜色显示。
我是用vi test.c进入的vim,而且current profile->colors->palette中选中了linux concole。
请指教怎么能找回语法的分颜色显示,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-31 19:18 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
/usr/share/vim/vim70/ftplugin/java.vim
有没有这样的文件。

.vimrc里面加
" 开启语法高亮
syntax on


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-31 22:33 

注册: 2006-09-30 22:54
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
java.vim中找不到.vimrc,请问该怎么办?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-31 22:44 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
不是阿。是你的家目录的。less ~/.vimrc看看。是这个配置文件


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-31 22:57 

注册: 2006-09-30 22:54
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
你是说/home/下吗,没这个文件啊


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-01 14:34 

注册: 2006-10-26 21:31
帖子: 11
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
apt-get install vim-full


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-01 18:36 

注册: 2006-09-30 22:54
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
也是过了,依然不行。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-01 18:51 

注册: 2005-10-03 14:13
帖子: 273
地址: Tokushima, Japan
送出感谢: 0 次
接收感谢: 1
把gvim安装上试试,
sudo aptitude install gvim
这个问题很奇怪,我刚装上时也是这样,怎么弄也不好使,后来把gvim装上之后就好了。


_________________
致虚极,守静笃


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]vim 中语法不能分颜色显示,而且profile中设置过了。 请指教!
帖子发表于 : 2006-11-06 20:36 

注册: 2006-10-28 21:14
帖子: 53
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
jasonding 写道:
用vim编辑c程序时,语法不能分颜色显示。
我是用vi test.c进入的vim,而且current profile->colors->palette中选中了linux concole。
请指教怎么能找回语法的分颜色显示,谢谢!


修改/etc/vim/vimrc

找到这样一段话:
" Vim5 and later versions support syntax highlighting. Uncommenting the next
" line enables syntax highlighting by default.
" syntax on

然后把" syntax on的那个"去掉即可。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-08 21:44 

注册: 2007-04-29 19:44
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
great!

thanks to jianliang79.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-11 18:51 

注册: 2006-10-24 0:00
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我也曾遇到类似问题,怎么改配置都没用。
后来发现我的ubuntu装好后自带的vim是精简版。
在新立得里搜了一下,把完整的vim装上,就ok了。

不知道这个信息对你有没有用?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-05-22 9:30 

注册: 2006-12-16 10:19
帖子: 81
送出感谢: 1
接收感谢: 0 次
这样也可,打开vim
:syntax enable


_________________
Linux桌面中文网|http://linuxdesktop.cn/


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-08-13 12:07 

注册: 2007-08-13 11:18
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
1. cp /etc/vim/vimrc ~/.vimrc
2. vi ~/.vimrc
3. 將 syntax on 前的 ” 拿掉即可


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-08-15 16:33 

注册: 2007-01-22 9:04
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我在新立得装的..也把那个Vim-full给装上了...就是要把那个Syntax on 前的"去了就可以了...

谢谢各位大虾的帮助...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译