emacs的cedet插件配置不成功

Vim、Emacs配置和使用
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

emacs的cedet插件配置不成功

#1

帖子 cnfczn » 2010-12-18 18:28

看完置顶帖的内容,还是没能把cedet配置好。
又从emacser上找,,配置方法和置顶帖一样,还是不成。

我装的emacs是apt-get install emacs安装的。
cedet是http://cedet.sourceforge.net/下载的1.0pre7。
前两步,,复制cedet1.0pre7到/usr/share/emacs/site-lisp/,然后make EMACS=emacs都没有问题
可是修改完.emacs文件,总是提示方法未定义
下面是.emacs文件添加的内容
(load-file "/usr/share/emacs/site-lisp/cedet-1.0pre7/common/cedet.el")
(require 'cedet)
(semantic-load-enable-code-helpers)
(semantic-load-enable-semantic-debugging-helpers)

麻烦大家帮帮忙,我做的哪步有问题啊?
上次由 cnfczn 在 2010-12-20 17:30,总共编辑 1 次。
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置

#2

帖子 cnfczn » 2010-12-18 19:01

打开 emacs
M-x load-library
cedet是已经加载的,可是查看cedet-version
如下:
cedet: 1.0pre7 ok ok
eieio: 1.2 ok ok
semantic: 2.0pre7 ok Not Loaded
srecode: 1.0pre7 ok Not Loaded
ede: 1.0pre7 ok ok
speedbar: 1.0.3 ok ok
cogre: 1.0pre7 ok Not Loaded
cedet-contrib: 1.0pre7 ok Not Loaded
发现semantic未加载,应该怎么加载semantic啊?
yupeng820921
帖子: 94
注册时间: 2009-02-25 19:44
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置

#3

帖子 yupeng820921 » 2010-12-19 22:55

打开一个.c文件是不是就自动加载了?
风间星魂
帖子: 490
注册时间: 2009-06-20 23:53
送出感谢: 3 次
接收感谢: 0

Re: emacs的cedet插件配置

#4

帖子 风间星魂 » 2010-12-19 23:36

如果是emacs 23.2直接在菜单里配置。
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置

#5

帖子 cnfczn » 2010-12-20 16:50

打开.c或.cpp都没有自动加载。
因为我把配置写在了.emacs里了,,所以刚打开就报错。
打开c++文件还是没能加载。
ubuntu 自动安装的emacs是23.1.1版的
GNU Emacs 23.1.1 (i486-pc-linux-gnu, GTK+ Version 2.20.0)

23.2好像缺少了很多cedet1.0pre7的东西,代码折叠和自动补全都不好使
http://emacser.com/built-in-cedet.htm

所以还是希望那个能在23.1下配置cedet
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置

#6

帖子 cnfczn » 2010-12-20 17:30

谁能指点下,,都两天了,,还是没找出来原因。
yupeng820921
帖子: 94
注册时间: 2009-02-25 19:44
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#7

帖子 yupeng820921 » 2010-12-20 22:33

(semantic-load-enable-code-helpers)
(semantic-load-enable-semantic-debugging-helpers)
这两个是不是重复了? 去掉后面那个试试。
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#8

帖子 cnfczn » 2010-12-21 0:09

这个也试了,,,如果两个都注释掉就没有问题.
5种模式后边肯定是前边的合集.随便开哪个,都会报未定义的错误.
头像
cpu太雷
帖子: 85
注册时间: 2010-07-25 14:00
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#9

帖子 cpu太雷 » 2010-12-21 14:32

用了下你的配置,然后没问题semantic顺利加载 :em04
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#10

帖子 cnfczn » 2010-12-21 16:37

:em24 版本和安装也都一样吗??
我就弄了个中文菜单和主题颜色.
而且我把插件加载放到了第一行,可是依然报错.
yupeng820921
帖子: 94
注册时间: 2009-02-25 19:44
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#11

帖子 yupeng820921 » 2010-12-22 12:32

首先清空你的.emacs,只保留cedet的部分,不加其他任何东西,试试看。

然后,找找网上有没有编译好的版本,试试。

最后,在别人电脑上试试。话说我以前安cedet,发现配置ede总是有问题,直接跑到邮件列表上问,eric让我使用了各种debug方法,然后把调试信息发给他看,帮我搞了一个星期也没有头绪,最后我重装系统,就一切正常了,惭愧死。。。
头像
cpu太雷
帖子: 85
注册时间: 2010-07-25 14:00
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#12

帖子 cpu太雷 » 2010-12-22 13:46

emacs23.2,cedet1p6
附件
ced.JPG
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#13

帖子 cnfczn » 2010-12-23 11:46

这两天有点事,没注意...
我是23.1和pre7的该不会跟这个有关系吧.
听说emacs23.2自带了cedet...= =!可是是缩水版的...
头像
cpu太雷
帖子: 85
注册时间: 2010-07-25 14:00
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#14

帖子 cpu太雷 » 2010-12-23 13:16

我这边在windows底下用的23.1和p6,还是图上那个配置文件也没问题
头像
cnfczn
帖子: 22
注册时间: 2008-11-08 22:41
送出感谢: 0
接收感谢: 0

Re: emacs的cedet插件配置不成功

#15

帖子 cnfczn » 2010-12-24 1:15

哦,成!今天太晚啦,明天起来试下!
回复

回到 “Vim和Emacs”