求助:安装emacs出现错误?

Vim、Emacs配置和使用
回复
头像
lendage
帖子: 22
注册时间: 2009-04-12 10:56
来自: 湖南
送出感谢: 0
接收感谢: 0
联系:

求助:安装emacs出现错误?

#1

帖子 lendage » 2011-01-21 1:29

具体情况是这样,系统是ubuntu10.10,之前安装ruby某个gem,貌似是postgresql的pg,安装国emacs23,因为当时在用vim所以就果断的卸载了,但卸载之后输入 emacs还会运行原始GTK界面的emacs,最近想重装,果断的

代码: 全选

sudo apt-get install emacs23
之后出现了下面的结果:
[quote][lenage@ubuntu:~$ sudo apt-get install emacs23
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包将被【卸载】:
emacs23-lucid
下列【新】软件包将被安装:
emacs23
升级了 0 个软件包,新安装了 1 个软件包,要卸载 1 个软件包,有 0 个软件包未被升级。
需要下载 3,038kB 的软件包。
解压缩后会消耗掉 4,096B 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://cn.archive.ubuntu.com/ubuntu/ maverick/main emacs23 i386 23.1+1-4ubuntu7 [3,038kB]
下载 3,038kB,耗时 8秒 (359kB/s)
dpkg:emacs23-lucid:有依赖问题,但是如您所愿还是继续卸载:
emacs 依赖于 emacs23 | emacs23-lucid | emacs23-nox;然而:
未安装软件包“emacs23”。
提供了 emacs23 的软件包 emacs23-lucid 即将被删除。
即将删除 emacs23-lucid。
未安装软件包“emacs23-nox”。
emacs 依赖于 emacs23 | emacs23-lucid | emacs23-nox;然而:
未安装软件包“emacs23”。
提供了 emacs23 的软件包 emacs23-lucid 即将被删除。
即将删除 emacs23-lucid。
未安装软件包“emacs23-nox”。
(正在读取数据库 ... 系统当前共安装有 255349 个文件和目录。)
正在卸载 emacs23-lucid ...
emacs-remove emacs23
remove/ruby1.8-elisp: purging byte-compiled files for emacs23
remove/gtk-doc-tools: purging byte-compiled files for emacs23
emacsen-common: Handling removal of emacsen flavor emacs23
emacsen-common: purging byte-compiled files for emacs23
正在处理用于 menu 的触发器...
正在处理用于 python-gmenu 的触发器...
Rebuilding /usr/share/applications/desktop.zh_CN.utf8.cache...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 man-db 的触发器...
正在处理用于 python-support 的触发器...
选中了曾被取消选择的软件包 emacs23。
(正在读取数据库 ... 系统当前共安装有 255338 个文件和目录。)
正在解压缩 emacs23 (从 .../emacs23_23.1+1-4ubuntu7_i386.deb) ...
正在处理用于 man-db 的触发器...
正在处理用于 python-gmenu 的触发器...
Rebuilding /usr/share/applications/desktop.zh_CN.utf8.cache...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 menu 的触发器...
正在处理用于 python-support 的触发器...
正在设置 emacs23 (23.1+1-4ubuntu7) ...
update-alternatives: 使用 /usr/bin/emacs23-x 来提供 /usr/bin/emacs (emacs),于 自动模式 中。
update-alternatives: 警告: 跳过创建 /usr/share/man/man1/emacs.1.gz 因为所关联文件 /usr/share/man/man1/emacs.emacs23.1.gz (位于链接组 emacs)不存在。
emacs-install emacs23
install/dictionaries-common: Byte-compiling for emacsen flavour emacs23
Warning: Lisp directory `/etc/emacs23' does not exist.
Wrote /usr/share/emacs23/site-lisp/dictionaries-common/debian-ispell.elc
Wrote /usr/share/emacs23/site-lisp/dictionaries-common/ispell.elc
Wrote /usr/share/emacs23/site-lisp/dictionaries-common/flyspell.elc
emacsen-common: Handling install of emacsen flavor emacs23
emacsen-common: byte-compiling for emacs23
cp: 无法创建普通文件“/etc/emacs23/site-start.d”: 没有那个文件或目录
emacs-install: /usr/lib/emacsen-common/packages/install/emacsen-common emacs23 failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 4.
dpkg:处理 emacs23 (--configure)时出错:
子进程 已安装 post-installation 脚本 返回了错误号 1
在处理时有错误发生:
emacs23
E: Sub-process /usr/bin/dpkg returned an error code (1)
/quote]
求高人指点,现在在终端运行emacs23还能运行,想问下上面是基于什么原因,要自己建文件还是?权限问题?
运行时的错误信息:
lenage@ubuntu:~$ sudo emacs
Warning: Lisp directory `/etc/emacs23' does not exist.
头像
lendage
帖子: 22
注册时间: 2009-04-12 10:56
来自: 湖南
送出感谢: 0
接收感谢: 0
联系:

Re: 求助:安装emacs出现错误?

#2

帖子 lendage » 2011-01-24 21:21

OK,问题解决,只要自己信念见 /etc/emacs23 文件夹 天下太平了就
回复

回到 “Vim和Emacs”