当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Edgy中的VI不支持语法高亮吗?
帖子发表于 : 2006-11-16 23:10 

注册: 2006-10-24 10:37
帖子: 207
送出感谢: 0 次
接收感谢: 0 次
我设置syntax on时,显示
E319:sorry,the command is not available in this version.

请问如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-17 12:57 
头像

注册: 2006-03-14 10:25
帖子: 630
送出感谢: 1
接收感谢: 4
edgy缺省的vim版本是vim-tiny,不支持语法高亮。
安装vim之后,就好了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-17 15:25 

注册: 2006-10-24 10:37
帖子: 207
送出感谢: 0 次
接收感谢: 0 次
感谢!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-08 3:59 

注册: 2006-06-02 10:42
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我也一样的问题,谢谢了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-08 13:47 
头像

注册: 2005-10-16 13:24
帖子: 958
地址: 四川成都
送出感谢: 2
接收感谢: 0 次
sudo apt-get install vim-full
cp /usr/share/vim/vimcurrent/vimrc_example.vim ~/yuk/.vimrc


_________________
Thank you Ubuntu Team!!!!
I still can't belive this is free...


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-14 17:01 

注册: 2007-02-04 13:19
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
安装vim后,如果还没有高亮,按如下设置
一:如过没有~/.vimrc的话,先创建该文件;
二:在文件中写入:
set autoindent
set cindent
set modeline
set ruler
set showcmd
set showfulltag
set showmode
set smartcase
set smartindent
set imcmdline
set previewwindow
set hlsearch
syntax on

syntax on这一设置就是语法高亮显示,set autoindent是自动缩进,别的有待进一步查证

三:此时如果没有彩色显示的话
在/etc/profile中写入
export TERM=xterm-color


页首
 用户资料  
 
7 楼 
 文章标题 : vim 7.0
帖子发表于 : 2007-03-18 14:55 

注册: 2007-01-25 0:22
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
vim 7.0后使用:
syntax enable
或者在/usr/share/vim/vim70/debian.vim中加入:
if &t_Co > 1
syntax enable
endif


页首
 用户资料  
 
8 楼 
 文章标题 : 行号
帖子发表于 : 2007-03-18 14:56 

注册: 2007-01-25 0:22
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
set nu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译