当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Mew无法连接SSL
帖子发表于 : 2011-03-25 1:09 
头像

注册: 2011-03-18 0:54
帖子: 97
送出感谢: 0 次
接收感谢: 2
本人机器:Archlinux+emacs23.3+mew6.5,使用mew的时候,总是出现
代码:
Creating an SSL/TLS connection......

这个错误。在Ubuntu上是完全可以工作的,不知道为什么在Arch上就不能正常工作了。
stunnel已经装上,配置文件stunnel.conf如下:
代码:
; Sample stunnel configuration file by Michal Trojnara 2002-2010
;
; some options used here may not be adequate for your particular configuration
; please read the manual and make sure you understand them

; certificate/key is needed in server mode and optional in client mode
cert = /etc/stunnel/mail.pem
;key = /etc/stunnel/mail.pem

; protocol version (all, SSLv2, SSLv3, TLSv1)
sslVersion = SSLv3

; security enhancements for UNIX systems - comment them out on Win32
; for chroot a copy of some devices and files is needed within the jail
chroot = /var/run/stunnel
setuid = stunnel
setgid = stunnel
; PID is created inside the chroot jail
pid = /stunnel.pid

; performance tunings
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
;compression = zlib

; workaround for Eudora bug
;options = DONT_INSERT_EMPTY_FRAGMENTS

; authentication stuff needs to be configured to prevent MITM attacks
; it is not enabled by default!
;verify = 2
; don't forget to c_rehash CApath
; CApath is located inside chroot jail
;CApath = /certs
; it's often easier to use CAfile
;CAfile = /etc/stunnel/certs.pem
; don't forget to c_rehash CRLpath
; CRLpath is located inside chroot jail
;CRLpath = /crls
; alternatively CRLfile can be used
;CRLfile = /etc/stunnel/crls.pem

; debugging stuff (may useful for troubleshooting)
debug = 7
output = stunnel.log

;libwrap = no

; SSL client mode
client = yes

; service-level configuration

[GMail_POP]
accept  = 127.0.0.1:3001
connect = pop.gmail.com:995

[GMail_SMTP]
accept  = 127.0.0.1:3002
connect = smtp.gmail.com:465

[GMail_IMAP]
accept  = 127.0.0.1:3003
connect = imap.gmail.com:993

;[https]
;accept  = 443
;connect = 80
;TIMEOUTclose = 0

; vim:ft=dosini

能成功启动。
.mew.el配置如下:
代码:
(setq mew-use-cached-passwd t)

(setq mew-config-alist
      '(("default"
         ("name" . "xxx")
         ("user" . "user")
         ("mail-domain" . "gmail.com")
         ("imap-ssl" . t)
         ("imap-ssl-port" . "3003")
         ("proto" . "%")
         ("prog-ssl" . "/usr/bin/stunnel")
         ("imap-auth" . pass)
         ("imap-user" . "xxx@gmail.com")
         ("imap-server" . "127.0.0.1")
         ("smtp-ssl" . t)
         ("smtp-ssl-port" . "3002")
         ("smtp-user" . "xxx@gmail.com")
         ("smtp-server" . "127.0.0.1")
         ("smtp-auth-list" . ("PLAIN")))
        ))
(setq mew-ssl-verify-level 0)

这个问题困扰了我很久,各位帮忙看看,谢谢了 :em01


_________________
写代码的汉子/你威武雄壮/飞驰的代码/像疾风一样/一望无际的BUG/随你去流浪/你的口袋像戈壁一样空旷

Ubuntu12.04+Emacs24+HHKB+Git


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Mew无法连接SSL
帖子发表于 : 2011-03-28 10:09 

注册: 2009-01-17 17:28
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
neaghfoz 写道:
本人机器:Archlinux+emacs23.3+mew6.5,使用mew的时候,总是出现
代码:
Creating an SSL/TLS connection......

这个错误。在Ubuntu上是完全可以工作的,不知道为什么在Arch上就不能正常工作了。
stunnel已经装上,配置文件stunnel.conf如下:
代码:
; Sample stunnel configuration file by Michal Trojnara 2002-2010
;
; some options used here may not be adequate for your particular configuration
; please read the manual and make sure you understand them

; certificate/key is needed in server mode and optional in client mode
cert = /etc/stunnel/mail.pem
;key = /etc/stunnel/mail.pem

; protocol version (all, SSLv2, SSLv3, TLSv1)
sslVersion = SSLv3

; security enhancements for UNIX systems - comment them out on Win32
; for chroot a copy of some devices and files is needed within the jail
chroot = /var/run/stunnel
setuid = stunnel
setgid = stunnel
; PID is created inside the chroot jail
pid = /stunnel.pid

; performance tunings
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
;compression = zlib

; workaround for Eudora bug
;options = DONT_INSERT_EMPTY_FRAGMENTS

; authentication stuff needs to be configured to prevent MITM attacks
; it is not enabled by default!
;verify = 2
; don't forget to c_rehash CApath
; CApath is located inside chroot jail
;CApath = /certs
; it's often easier to use CAfile
;CAfile = /etc/stunnel/certs.pem
; don't forget to c_rehash CRLpath
; CRLpath is located inside chroot jail
;CRLpath = /crls
; alternatively CRLfile can be used
;CRLfile = /etc/stunnel/crls.pem

; debugging stuff (may useful for troubleshooting)
debug = 7
output = stunnel.log

;libwrap = no

; SSL client mode
client = yes

; service-level configuration

[GMail_POP]
accept  = 127.0.0.1:3001
connect = pop.gmail.com:995

[GMail_SMTP]
accept  = 127.0.0.1:3002
connect = smtp.gmail.com:465

[GMail_IMAP]
accept  = 127.0.0.1:3003
connect = imap.gmail.com:993

;[https]
;accept  = 443
;connect = 80
;TIMEOUTclose = 0

; vim:ft=dosini

能成功启动。
.mew.el配置如下:
代码:
(setq mew-use-cached-passwd t)

(setq mew-config-alist
      '(("default"
         ("name" . "xxx")
         ("user" . "user")
         ("mail-domain" . "gmail.com")
         ("imap-ssl" . t)
         ("imap-ssl-port" . "3003")
         ("proto" . "%")
         ("prog-ssl" . "/usr/bin/stunnel")
         ("imap-auth" . pass)
         ("imap-user" . "xxx@gmail.com")
         ("imap-server" . "127.0.0.1")
         ("smtp-ssl" . t)
         ("smtp-ssl-port" . "3002")
         ("smtp-user" . "xxx@gmail.com")
         ("smtp-server" . "127.0.0.1")
         ("smtp-auth-list" . ("PLAIN")))
        ))
(setq mew-ssl-verify-level 0)

这个问题困扰了我很久,各位帮忙看看,谢谢了 :em01


name 的 xxx 帐号?
还是贴上来的错了.
user 是帐号 name可以随意

参考下这个 http://www.mew.org/pipermail/mew-int/20 ... 02217.html


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译