ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

Vim、Emacs配置和使用
回复
头像
xinglu1983
帖子: 43
注册时间: 2008-07-08 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

#1

帖子 xinglu1983 » 2011-04-17 19:52

编辑安装的vim7.3:
./configure --prefix=/usr/local/modules/vim/vim73 --with-features=huge --enable-pythoninterp --enable-gui=gnome2 --enable-cscope --enable-fontset --enable-perlinterp --enable-tclinterp --enable-multibyte

系统自带的python2.6 , 我又装了python3.1

vim装了conque_shell插件后,还是用不了,提示:
Conque ERROR: Python interface cannot be loaded

Your version of Vim appears to be installed without the Python interface.

You are using a Unix-like operating system. Most, if not all, of the popular
Linux package managers have Python-enabled Vim available. For example
vim-gnome or vim-gtk on Ubuntu will get you everything you need.

If you are compiling Vim from source, make sure you use the --enable-pythoninterp
configure option. You will also need to install Python and the Python headers.

If you are using OS X, MacVim will give you Python support by default.
头像
lilydjwg
论坛版主
帖子: 4165
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

#2

帖子 lilydjwg » 2011-04-17 20:50

你没装 Python 的开发包吧。Ubuntu 下开发用的文件会另外打包的。另外,现在很多软件用的是 Python 2。
头像
adam8157
帖子: 2794
注册时间: 2009-03-05 16:31
送出感谢: 0
接收感谢: 8 次
联系:

Re: ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

#3

帖子 adam8157 » 2011-04-17 21:01

其实, 用screen另外开窗口挺好的...不必conque_shell
头像
lilydjwg
论坛版主
帖子: 4165
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

#4

帖子 lilydjwg » 2011-04-17 23:12

adam8157 写了:其实, 用screen另外开窗口挺好的...不必conque_shell
用 tmux 更好,可以像 Vim 那样分隔窗口。
头像
xinglu1983
帖子: 43
注册时间: 2008-07-08 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu10.10 vim7.3 装了python3,为什么还是用不了conque_shell?

#5

帖子 xinglu1983 » 2011-04-17 23:54

adam8157 写了:其实, 用screen另外开窗口挺好的...不必conque_shell
我现在就是在用这种方式,主要是想体验下conque_shell这个插件,看看有什么特点,在win下装成功过,不过他的win支持不好,格式全是乱的。
回复

回到 “Vim和Emacs”