ubuntu10.10 vim73编译不上python、perl

Vim、Emacs配置和使用
回复
头像
xinglu1983
帖子: 43
注册时间: 2008-07-08 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

ubuntu10.10 vim73编译不上python、perl

#1

帖子 xinglu1983 » 2011-04-21 11:37

vim --version 里面:
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr 21 2011 11:27:24)
编译者 xinglu@xinglu-ThinkCentre
巨型版本 带 GTK2 图形界面。
可使用(+)与不可使用(-)的功能:
...................
-perl -python -python3
...................

是不是代表这几个功能不可用?没有编译成功吗?


我的编译参数:
./configure --prefix=/usr/local/modules/vim/vim73 --with-features=huge --enable-pythoninterp=yes --enable-python3interp=yes --enable-gui=gnome2 --enable-cscope --enable-fontset --enable-perlinterp --enable-tclinterp --enable-multibyte

python:
xinglu@xinglu-ThinkCentre:~/data/software/vim$ python --version
Python 2.6.6

xinglu@xinglu-ThinkCentre:~/data/software/vim$ python3 --version
Python 3.1.2

perl:
xinglu@xinglu-ThinkCentre:~/data/software/vim$ perl --version

This is perl, v5.10.1 (*) built for x86_64-linux-gnu-thread-multi
(with 40 registered patches, see perl -V for more detail)

Copyright 1987-2009, Larry Wall
头像
lilydjwg
论坛版主
帖子: 4163
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: ubuntu10.10 vim73编译不上python、perl

#2

帖子 lilydjwg » 2011-04-21 12:43

没装开发包吧?另外,Python 2 和 3 即使都编译上了(动态加载),也是不能同时使用的,你选一个吧。如果用 Python 3,记得到我博客下载修正补丁。
头像
xinglu1983
帖子: 43
注册时间: 2008-07-08 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu10.10 vim73编译不上python、perl

#3

帖子 xinglu1983 » 2011-04-21 13:04

lilydjwg 写了:没装开发包吧?另外,Python 2 和 3 即使都编译上了(动态加载),也是不能同时使用的,你选一个吧。如果用 Python 3,记得到我博客下载修正补丁。
开发包怎么安装呢?
python只能编译一个啊?那我重新编译下去,然后去下载修正补丁。
头像
lilydjwg
论坛版主
帖子: 4163
注册时间: 2009-04-11 23:46
系统: Arch Linux
送出感谢: 11 次
接收感谢: 127 次
联系:

Re: ubuntu10.10 vim73编译不上python、perl

#4

帖子 lilydjwg » 2011-04-21 13:30

xinglu1983 写了: 开发包怎么安装呢?
python只能编译一个啊?那我重新编译下去,然后去下载修正补丁。
python31-dev 。Debian/Ubuntu 开发用的文件都是单独打包的,包名有后缀 -dev。
头像
xinglu1983
帖子: 43
注册时间: 2008-07-08 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu10.10 vim73编译不上python、perl

#5

帖子 xinglu1983 » 2011-04-21 17:59

lilydjwg 写了:
xinglu1983 写了: 开发包怎么安装呢?
python只能编译一个啊?那我重新编译下去,然后去下载修正补丁。
python31-dev 。Debian/Ubuntu 开发用的文件都是单独打包的,包名有后缀 -dev。
解决了,的确是开发包没有装造成的,多谢~!
回复

回到 “Vim和Emacs”