当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 奇了怪了,没法装color theme【已解决】
帖子发表于 : 2011-05-17 11:38 

注册: 2008-07-09 21:37
帖子: 82
送出感谢: 1
接收感谢: 0 次
我已经没办法了,怎么都不成功 ……………………
我把color theme 6.6.0放到.emacs.d下
然后
(add-to-list 'load-path /home/crazybanana/.emacs.d")
(require ‘color-theme)
(color-theme-initialize)
= =失败………………


最后由 demonhack 编辑于 2011-05-18 14:07,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 奇了怪了,没法装color theme
帖子发表于 : 2011-05-17 12:12 
头像

注册: 2009-07-25 1:57
帖子: 701
送出感谢: 5
接收感谢: 13
错误提示是啥?--debug-init启动看看

恩,不用了,你命令打错了。。。
代码:
(add-to-list 'load-path "/home/crazybanana/.emacs.d")

下次自己检查下好吗,不要这种就发上来。


_________________
https://github.com/tangboyun
http://tangboyun.is-programmer.com/
提问的智慧————Eric Steven Raymond
回答的智慧————Andrew Clarke
吾尝终日而思矣,不如须臾之所学也;吾尝跂而望矣,不如登高之博见也。
急急急标题什么的,最讨厌了!
急急复急急,急急何其多,我生待急急,万事急急急。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 奇了怪了,没法装color theme
帖子发表于 : 2011-05-17 16:23 

注册: 2008-07-09 21:37
帖子: 82
送出感谢: 1
接收感谢: 0 次
tangboyun 写道:
错误提示是啥?--debug-init启动看看

恩,不用了,你命令打错了。。。
代码:
(add-to-list 'load-path "/home/crazybanana/.emacs.d")

下次自己检查下好吗,不要这种就发上来。

= =好吧我是打错了,问题是我改了还是老样子。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 奇了怪了,没法装color theme
帖子发表于 : 2011-05-17 23:59 
头像

注册: 2009-07-25 1:57
帖子: 701
送出感谢: 5
接收感谢: 13
demonhack 写道:
= =好吧我是打错了,问题是我改了还是老样子。

代码:
(require 'color-theme)

你这句用了中文的上引号把,另外出错贴debug信息啊,这不是个 yes | no的问题啊。


_________________
https://github.com/tangboyun
http://tangboyun.is-programmer.com/
提问的智慧————Eric Steven Raymond
回答的智慧————Andrew Clarke
吾尝终日而思矣,不如须臾之所学也;吾尝跂而望矣,不如登高之博见也。
急急急标题什么的,最讨厌了!
急急复急急,急急何其多,我生待急急,万事急急急。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 奇了怪了,没法装color theme
帖子发表于 : 2011-05-18 14:03 

注册: 2008-07-09 21:37
帖子: 82
送出感谢: 1
接收感谢: 0 次
代码:
Warning (initialization): An error occurred while loading `/home/crazybanana/.emacs':

Symbol's function definition is void: color-theme-initialize

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the `--debug-init' option to view a complete error backtrace.

= =
另外我没启用中文输入法的引号
--debug-init的信息贴不上来…………………………


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 奇了怪了,没法装color theme
帖子发表于 : 2011-05-18 14:07 

注册: 2008-07-09 21:37
帖子: 82
送出感谢: 1
接收感谢: 0 次
搞好了………………谢谢帮忙了…………………………话说我这个人还真是毛燥………
(require 'color-theme)
(color-theme-initialize)
这两行我后来改的时候把位置互换了没换回来…………
= =不好意思啊…………


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译