当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-03 21:39 
头像

注册: 2010-12-20 14:01
帖子: 130
送出感谢: 10
接收感谢: 0 次
最近刚学习VIM,但是碰到一个问题请教一下各位大侠,就是用q命令记录的寄存器内容会变成乱码,这个不知道如何解决呢?
补充一下,我目前的环境是XP,VIM编码设置我不太懂是什么意思,是这个吗
let &termencoding=&encoding
set fileencodings=utf-8
如图:


附件:
寄存器乱码.jpg
寄存器乱码.jpg [ 20.27 KiB | 被浏览 1126 次 ]



_________________
本人linux菜鸟,请各位大虾原谅我的无知和愚蠢


最后由 xinu 编辑于 2013-02-03 22:57,总共编辑了 2 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-03 21:45 

注册: 2012-12-20 15:39
帖子: 128
系统: Debian sid
送出感谢: 0 次
接收感谢: 4
你用的什么编码方式, 我用utf8, 没有问题.
难不成你是在windows的gbk中文环境?


附件:
vim register.png
vim register.png [ 4.62 KiB | 被浏览 1117 次 ]
页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-03 22:56 
头像

注册: 2010-12-20 14:01
帖子: 130
送出感谢: 10
接收感谢: 0 次
libreoffice3writer 写道:
你用的什么编码方式, 我用utf8, 没有问题.
难不成你是在windows的gbk中文环境?

非常感谢你的回复,我目前是用XP,乱码的部分并不是中文,目前发现是不知道为什么“多”出来的部分,比如我图中a寄存器的内容,其实我只是记录了
^i\#include[Esc]$a"[Esc]j
但不知道为什么$a"后面会蹦2个我都不会打的字出来,但是寄存器中的内容还是可以用的,并不会多出那2个不知道什么字,就是看起来“不好看”,有时候会搞不清楚寄存器里面到底是什么 :em06


_________________
本人linux菜鸟,请各位大虾原谅我的无知和愚蠢


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-03 23:37 

注册: 2012-12-20 15:39
帖子: 128
系统: Debian sid
送出感谢: 0 次
接收感谢: 4
我现在去虚拟机中测试一下, 看看gvim在gbk环境下会出现什么问题.


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-03 23:54 

注册: 2012-12-20 15:39
帖子: 128
系统: Debian sid
送出感谢: 0 次
接收感谢: 4
我试了一下, 在windows xp sp3中, gvim不存在乱码的问题. 但有些问题要注意.
因为windows中文环境是GBK编码(也就是cp936), 而gvim内部是utf-8, 总会在一些地方出现乱码问题.
如果用gvim编辑的文件是用cp936编码格式的话, 不会存在乱码;
如果用gvim编辑的文件是用utf-8编码格式的话, vim命令(中文提示)会出现乱码;

安装gvim, 会有一些方装内容的选择, 其中的最后一条是本地话语方支持(Native Language Support), 我在测试时选择了这个选项.


附件:
gvim on windows(installation without Native Language Support).png
gvim on windows(installation without Native Language Support).png [ 5.38 KiB | 被浏览 1082 次 ]
gvim on windows(installation).png
gvim on windows(installation).png [ 9.49 KiB | 被浏览 1082 次 ]
gvim on windows (using utf-8).png
gvim on windows (using utf-8).png [ 3.65 KiB | 被浏览 1082 次 ]
gvim on windows(using cp936).png
gvim on windows(using cp936).png [ 3.43 KiB | 被浏览 1082 次 ]

_________________
评价: 3.7% xinu
 
页首
 用户资料  
 
6 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-04 0:04 

注册: 2012-12-20 15:39
帖子: 128
系统: Debian sid
送出感谢: 0 次
接收感谢: 4
如果安装时没有选择Native Language Support的话, gvim的界面及命令提示都是英文, 也没有乱码出现.

但以上情况, 都没有出现楼主反映的问题-- register中出现乱码.


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 请教一下gvim寄存器乱码的问题
帖子发表于 : 2013-02-04 21:33 
头像

注册: 2010-12-20 14:01
帖子: 130
送出感谢: 10
接收感谢: 0 次
libreoffice3writer 写道:
我试了一下, 在windows xp sp3中, gvim不存在乱码的问题. 但有些问题要注意.
因为windows中文环境是GBK编码(也就是cp936), 而gvim内部是utf-8, 总会在一些地方出现乱码问题.
如果用gvim编辑的文件是用cp936编码格式的话, 不会存在乱码;
如果用gvim编辑的文件是用utf-8编码格式的话, vim命令(中文提示)会出现乱码;

安装gvim, 会有一些方装内容的选择, 其中的最后一条是本地话语方支持(Native Language Support), 我在测试时选择了这个选项.

非常感谢,我自己在鼓捣一下看看吧 :em01


_________________
本人linux菜鸟,请各位大虾原谅我的无知和愚蠢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译