emacs 23 的 xft 字体的简单设置

Vim、Emacs配置和使用
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

emacs 23 的 xft 字体的简单设置

#1

帖子 zhan » 2007-02-04 13:24

6.10 适用,其他的能不能用我就不知道了。
试过了,7.04 也可以直接用。
支持 xft 字体,具体设置为 在 .emacs 文件中加入

代码: 全选

(set-fontset-font "fontset-default"
                  'gb18030 '("AR PL ShanHeiSun Uni" . "unicode-bmp")) 
当然这个是从 karron 的帖子中看到的。 ^_^
启动的时候用 emacs --enable-font-backend -fn "BitStream Vera Sans Mono-12" 这样的方法。
怕麻烦的就在 .bashrc 中写上一句

代码: 全选

alias xftemacs='emacs --enable-font-backend -fn "BitStream Vera Sans Mono-12"'
然后新启动一个终端,在那里就可以用 xftemacs 启动了。
当然,像 AR PL ** 和 BitStream ** 的字体可以换成你系统中的字体,不过这两款字体是 ubuntu 默认就有的。那个 gb18030 后面要跟中文字体,比如 WenQuanYi 等等的,这些字体名称可以用 fc-list 查看。

废话不说了,由于网络比较郁闷没有传到 ftp 上的条件,我把这个报放在这里了,大家可以下载:
http://mail.ustc.edu.cn/~abxeeled/edgy/ ... 2_i386.deb 应该是能够下载的。有什么问题的话跟帖提出..

更新一下几个需要注意的地方:
一,上面的一些东西是针对前些时间的 emacs 的,而且是我个人打的包,可能会有一些问题。现在推荐一个第三方源上面的 emacs, 这个是按照 debian/ubuntu 的标准打包的,并且更新也很快。

代码: 全选

deb http://ppa.launchpad.net/avassalotti/ubuntu gutsy main
deb-src http://ppa.launchpad.net/avassalotti/ubuntu gutsy main 

其中的 emacs-snapshot 这个包就是,不是一个整的包,而是分成了几个。
这个目前的版本已经是 23.0.60, 集合了 xft, unicode支持 和 multi-tty, 虽然可能会有些不稳定的因素。
二,设置部分,以下面的为准,上面的就当一个历史回顾留着吧。。。 我也懒得删除了。。。

============更新一下,本来回了帖子了,想了想,还是放到主帖吧========

matri 说她的配置出现韩文,测试了一下,确实有这个问题,而且搜索了一下,貌似是 emacs 本身的问题。

给个新包吧: http://mail.ustc.edu.cn/~abxeeled/emacs ... 1_i386.deb 测试环境 feisty 貌似是5月底的包。记不得几号了。

关于中文的配置简单了,先写个 ~/.Xresources,没有的话自己建立 我的如下

代码: 全选

$cat ~/.Xresources
Xft.antialias: 1
Xft.hinting: 1
Xft.hintstyle: hintfull
!Xft.rgba: rgb  # 这行一般没有什么必要,特别是 CRT 用户,而且貌似还要结合 cleartype 的补丁使用。

Emacs.FontBackend: xft
然后设置一下 .emacs
加入下面的部分

代码: 全选

(set-default-font "Bitstream Vera Sans Mono-12")
 (set-fontset-font (frame-parameter nil 'font)
              'han '("WenQuanYi Bitmap Song" . "unicode-bmp"))
这样的话,英文是 BitStream Vera Sans Mono,12 号, 中文是 WenQuanYi Bitmap Song,这个按照自己的喜好选吧, fc-list 一下,输出的中文字体都可以放进去。
记得把其他地方关于 emacs 字体的设置去掉。

设置好了直接启用 emacs 应该就是 xft 字体的显示了。

不要再 --enable-font-backend 的配置了。

提一下,这样设置有个问题,就是上面字体设置的第二句,如果只使用 ‘han 的话,可能就是只有汉字会使用指定的字体显示,标点等等不会,解决办法有两个,一个是将上面的 han 换成 unicode 就是

代码: 全选

(set-fontset-font (frame-parameter nil 'font)
              'unicode '("WenQuanYi Bitmap Song" . "unicode-bmp"))
还有一个办法就是分别指定标点的显示,这个比较麻烦了,比如指定

代码: 全选

(set-fontset-font (frame-parameter nil 'font)
              'symbol '("WenQuanYi Bitmap Song" . "unicode-bmp"))

可以让一部分标点用 wqy 显示,将上面的 symbol 换成 cjk-misc又可以让一部分标点正常显示,相应的变亮还有 bopomofo, 好像将这些都设置一下是能够让常用标点正常显示的,不过具体的对应关系我不很明白。个人认为还是上面的第一种办法简单。。。 大家自己取舍吧。
上次由 zhan 在 2008-01-04 0:33,总共编辑 7 次。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2007-02-04 13:29

你这个是用什么打包的?
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zhan » 2007-02-04 13:41

dpkg-buildpackage
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2007-02-04 14:28

详细解释一下怎么打
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zhan » 2007-02-04 14:40

主要是参考 maint-guide 的文档(有中文版的),emacs 打包很简单的,基本上没有什么问题。

代码: 全选

sudo aptitude install maint-guide-zh //这个是中文版
然后看文档就行了
文档的位置在 /usr/share/doc/maint-guide/maint-guide.zh_CN.html/index.html
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
esun2006
帖子: 52
注册时间: 2007-02-15 16:04
送出感谢: 0
接收感谢: 1 次

不错,请问你的编译参数是什么?

#6

帖子 esun2006 » 2007-02-16 0:00

我也编译了几变,但是不能直接使用scim,你的这个不用任何设置就能使用scim,羡慕哦。
讨教,使用什么参数编译的?

我的编译参数:
./configure --prefix=/usr --enable-font-backend --with-xft --with-freetype --with-gtk

编译完成后要设置LC_TYPE=zh_CN.GBK才能调用scim!!!郁闷!!

请问你的参数是什么?或者另外采用了什么手段?

谢谢
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 karron » 2007-02-16 8:22

楼上的去看我的一个帖子, 名字叫 据说最新版的emacs已经解决了gnome下输入法的问题. 就在本区.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 Beetle » 2007-02-22 12:43

scim不知道,不过新的emacs已经可以用fcitx了!
rleon
帖子: 6
注册时间: 2006-06-05 14:39
送出感谢: 0
接收感谢: 0

#9

帖子 rleon » 2007-03-01 17:06

太好了,最近在折腾 emacs muse ,老不能输入中文,这下好了
小刚paul
帖子: 7
注册时间: 2007-03-01 10:37
送出感谢: 0
接收感谢: 0

#10

帖子 小刚paul » 2007-03-23 16:55

在Dapper下边双击下载的这个包,提示 Error: Dependency is not satisfiable: libatk1.0-0
在新立得里,看到libatk1.0-0 好象是装了的,不知道啥原因
小刚paul
帖子: 7
注册时间: 2007-03-01 10:37
送出感谢: 0
接收感谢: 0

#11

帖子 小刚paul » 2007-03-23 17:10

tzdata_2007c-1_all.deb
libc6_2.3.6.ds1-13_i386.deb
libatk1.0-0_1.12.4-3_i386.deb
下了这几个包,准备安装一下,结果提示tzdata安装失败,因为这三个是依次相互依赖的,安装失败。可能在Edgy下编译的东西在Dapper下就是不太好用的吧,郁闷啊。Emacs果然不是人用的
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 zhan » 2007-03-25 11:27

问题应该是底层的库不兼容。所以 6.06 的应该用不了了,那还推荐一个地方,那个人编译了 dapper edgy feisty 各自适用的版本,名字叫 emacs-snapshot 的,去看看吧.
http://debs.peadrop.com/
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#13

帖子 BigSnake.NET » 2007-03-25 13:15

zhan 写了:问题应该是底层的库不兼容。所以 6.06 的应该用不了了,那还推荐一个地方,那个人编译了 dapper edgy feisty 各自适用的版本,名字叫 emacs-snapshot 的,去看看吧.
http://debs.peadrop.com/
zhan不厚道..这么好的东西现在才放出来 :)
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 zhan » 2007-04-01 11:09

某一天在 irc 的时候 karron 告诉我的..
我自己也不知道..
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
aaronfromchina
帖子: 79
注册时间: 2006-03-02 23:16
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 aaronfromchina » 2007-05-11 23:24

下载了deb,
在Feisty Fawn,用Fcitx输入法,完全正常。谢谢。

如果我想同时开多几个频道,请问如何切换呢?
回复

回到 “Vim和Emacs”