当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:Emacs文本编辑器插件Evil安装出错。附详情。
帖子发表于 : 2015-12-27 17:16 

注册: 2015-11-25 4:23
帖子: 71
系统: xubuntu16.04 amd64
送出感谢: 14
接收感谢: 0 次
正学习python中,之前用的vim但想用emacs 方便调试和长远。用Evil插件模拟vim
Install via el-get
没办法,没中文论坛,甚至英文论坛都无样,只有说明,但对于新人,不够细。
Loading 00debian-vars...done
Loading /etc/emacs/site-start.d/50autoconf.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...
Loading debian-ispell...
Loading /var/cache/dictionaries-common/emacsen-ispell-default.el (source)...done
Loading debian-ispell...done
Loading /var/cache/dictionaries-common/emacsen-ispell-dicts.el (source)...done
Loading /etc/emacs/site-start.d/50dictionaries-common.el (source)...done
Package evil previously failed to install, removing it first.
el-get: updating autoloads for evil
el-get: byte-compiling autoload file
evil removed: This package has been removed successfully by el-get.
el-get remove evil
For information about GNU Emacs and the GNU system, type C-h C-a.
Package evil previously failed to install, removing it first.
el-get: updating autoloads for evil
el-get: byte-compiling autoload file
evil removed: This package has been removed successfully by el-get.
el-get remove evil
el-get-executable-find: The command named 'hg' can not be found with `executable-find'
Contacting host: www.gnu.org:80 [2 times]
command-execute: Symbol's function definition is void: eww-quit [10 times]
completing-read-default: Command attempted to use minibuffer while in minibuffer [3 times]
el-get-read-recipe: El-get can not find a recipe for package ""
command-execute: Buffer is read-only: #<buffer *Warnings*>
delete-backward-char: Text is read-only [9 times]
el-get-read-cached-recipe: Package evil is nowhere to be found in el-get status file.
Mark set [2 times]
Saved text until "n el-get status file.
Mark set [2 times]"
byte-code: End of buffer
byte-code: Beginning of buffer
byte-code: End of buffer [4 times]
/usr/bin/emacs -Q -batch -L /home/evolution/.emacs.d/el-get/el-get/ -L /home/evolution/.emacs.d/el-get/el-get/methods -l /home/evolution/.emacs.d/el-get/el-get/methods/el-get-emacswiki -f el-get-emacswiki-build-local-recipes ~/.emacs.d/el-get/el-get/recipes/emacswiki/
el-get: EmacsWiki: EmacsWiki local recipe list refreshed
byte-code: End of buffer [4 times]
byte-code: Beginning of buffer [4 times]
byte-code: End of buffer [2 times]
user-error: Minibuffer window is not active
byte-code: End of buffer [3 times]
byte-code: Beginning of buffer [2 times]
Mark set
byte-code: End of buffer [13 times]
e is undefined
l is undefined
scroll-down-command: Beginning of buffer [5 times]
j is undefined
scroll-down-command: Beginning of buffer [2 times]
completing-read-default: Command attempted to use minibuffer while in minibuffer
delete-backward-char: Text is read-only [2 times]
execute-extended-command: `' is not a valid command name
Package evil previously failed to install, removing it first.
el-get: updating autoloads for evil
el-get: byte-compiling autoload file
evil removed: This package has been removed successfully by el-get.
el-get remove evil
el-get-executable-find: The command named 'hg' can not be found with `executable-find'


最后由 evolutionboy1 编辑于 2015-12-28 23:56,总共编辑了 6 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:Emacs 安装Evil via el-get 出现No match
帖子发表于 : 2015-12-27 19:40 

注册: 2009-08-04 16:33
帖子: 16930
送出感谢: 21
接收感谢: 1834
看看 有沒有關係
https://github.com/bradwright/emacs.d
python-mode
As of 24.2, Emacs ships with a robust Python mode. However, when navigating SnakeCase words (eg class names), forward-word etc don’t work correctly.
We can work around that using subword-mode:


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:Emacs 安装Evil via el-get 出现No match
帖子发表于 : 2015-12-27 19:53 

注册: 2015-11-25 4:23
帖子: 71
系统: xubuntu16.04 amd64
送出感谢: 14
接收感谢: 0 次
poloshiao 写道:
看看 有沒有關係
https://github.com/bradwright/emacs.d
python-mode
As of 24.2, Emacs ships with a robust Python mode. However, when navigating SnakeCase words (eg class names), forward-word etc don’t work correctly.
We can work around that using subword-mode:


我找的不是Python相关,
是找Emacs这个 文本编辑器的一个插件,
这个插件的功能是模拟VIM文本编辑器的按健方式,
这个插件我找到了,安装方法也找到了,
但是我第一次使用,始终安装出错,网上没这种初级的细节描述,找了好久没找到,来求助的。

您第一次发的那个链接就是的,http://www.emacswiki.org/emacs/Evil
其中一种安装方式是这样
Install via el-get

Evil can be alternatively downloaded and installed with:

M-x el-get-install RET evil RET
,,,,,,,,,,,,,,,
但我运行这命令总是错,不知道具体是怎么运行这个命令,
本来还有其它安装方式,但这种安装方式听说是最方便的简洁的,总是要会的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译