vim-latex-suite无法使用

Vim、Emacs配置和使用
回复
头像
majormeng
帖子: 147
注册时间: 2010-12-07 22:33
系统: DEBIAN+fvwm
送出感谢: 1 次
接收感谢: 0

vim-latex-suite无法使用

#1

帖子 majormeng » 2016-01-10 21:18

debian8,apt-get安装了vim,vim-latexsuite,但是打开.tex文件的时候<F5>键和ctrl-j什么的不起效果啊?
求教大神~~~~
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: vim-latex-suite无法使用

#2

帖子 vickycq » 2016-01-10 21:24

看说明,默认未启用

需要安装 vim-addon-manager 后运行

代码: 全选

vim-addons install latex-suite
并将以下内容加入 vimrc

代码: 全选

filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
/usr/share/doc/vim-latexsuite/README.Debian 写了: Dear user, this package provides the vim addon latex-suite, but it is not enabled per default. If you want to enable it for your user account execute:
vim-addons install latex-suite
Similarly, to enable it for all users of this system execute (as root):
vim-addons -w install latex-suite
vim-addons is provided by the vim-addon-manager package, have a look at its manpage for more information.

Additionally, you need to add the following lines
filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
to ~/.vimrc (or to /etc/vim/vimrc as root) for full usability.
For more info about this lines, type ":help ls_1" in vim (after enabling this plugin with vim-addons).
参考
https://packages.debian.org/jessie/vim-latexsuite
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
majormeng
帖子: 147
注册时间: 2010-12-07 22:33
系统: DEBIAN+fvwm
送出感谢: 1 次
接收感谢: 0

Re: vim-latex-suite无法使用

#3

帖子 majormeng » 2016-01-10 22:14

vickycq 写了:看说明,默认未启用

需要安装 vim-addon-manager 后运行

代码: 全选

vim-addons install latex-suite
并将以下内容加入 vimrc

代码: 全选

filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
/usr/share/doc/vim-latexsuite/README.Debian 写了: Dear user, this package provides the vim addon latex-suite, but it is not enabled per default. If you want to enable it for your user account execute:
vim-addons install latex-suite
Similarly, to enable it for all users of this system execute (as root):
vim-addons -w install latex-suite
vim-addons is provided by the vim-addon-manager package, have a look at its manpage for more information.

Additionally, you need to add the following lines
filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
to ~/.vimrc (or to /etc/vim/vimrc as root) for full usability.
For more info about this lines, type ":help ls_1" in vim (after enabling this plugin with vim-addons).
参考
https://packages.debian.org/jessie/vim-latexsuite
太感谢了,我一开始大致的看了一下help,没有看仔细,多谢告诉我啊。
头像
majormeng
帖子: 147
注册时间: 2010-12-07 22:33
系统: DEBIAN+fvwm
送出感谢: 1 次
接收感谢: 0

Re: vim-latex-suite无法使用

#4

帖子 majormeng » 2016-01-10 22:17

vickycq 写了:看说明,默认未启用

需要安装 vim-addon-manager 后运行

代码: 全选

vim-addons install latex-suite
并将以下内容加入 vimrc

代码: 全选

filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
/usr/share/doc/vim-latexsuite/README.Debian 写了: Dear user, this package provides the vim addon latex-suite, but it is not enabled per default. If you want to enable it for your user account execute:
vim-addons install latex-suite
Similarly, to enable it for all users of this system execute (as root):
vim-addons -w install latex-suite
vim-addons is provided by the vim-addon-manager package, have a look at its manpage for more information.

Additionally, you need to add the following lines
filetype plugin on
set grepprg=grep\ -nH\ $*
filetype indent on
let g:tex_flavor='latex'
to ~/.vimrc (or to /etc/vim/vimrc as root) for full usability.
For more info about this lines, type ":help ls_1" in vim (after enabling this plugin with vim-addons).
参考
https://packages.debian.org/jessie/vim-latexsuite
太感谢了,我一开始大致的看了一下help,没有看仔细,多谢告诉我啊。
回复

回到 “Vim和Emacs”