当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于emacs中显示中文标点符号的问题
帖子发表于 : 2007-07-12 17:34 

注册: 2007-07-09 16:37
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
按照置顶帖子顺利安装了emacs 23,字体配置为:
(create-fontset-from-fontset-spec
"-*-courier-medium-r-*-*-16-*-*-*-*-*-fontset-song,\
chinese-gb2312:-*-wenquanyi bitmap song-*-*-normal--16-*-*-*-*-*-iso10646-1,\
chinese-big5-1:-*-wenquanyi bitmap song-*-*-normal--16-*-*-*-*-*-iso10646-1,\
chinese-big5-2:-*-wenquanyi bitmap song-*-*-normal--16-*-*-*-*-*-iso10646-1,\
utf-8:-*-wenquanyi bitmap song-*-*-normal--16-*-*-*-*-*-iso10646-1")
(set-default-font "fontset-song")
(add-to-list 'after-make-frame-functions
(lambda (new-frame) (select-frame new-frame)
(set-default-font "fontset-song")))

但现在有个问题:所有的中文文字可以正常显示和输入,但中文标点符号都不正常,无论输入还是显示都为一个空心方块。请问是什么方面我设置错了?谢谢。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-12 20:54 

注册: 2007-07-09 16:37
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
怎么还没人帮顶阿?
刚才换了fcitx还是不行,应该不是输入法的问题。除了中文标点符号显示为方括号外其他都正常,而且那些显示为方括号的标点符号,用其他编辑器时都是正常的


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-13 6:43 

注册: 2007-07-09 16:37
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
现在可以了,卸载了emacs,按照http://forum.ubuntu.org.cn/viewtopic.php?t=29742的方法重新安装了emacs,现在终于可以正常显示中文标点符号了,可能我编译时少加了什么参数吧。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-14 9:36 

注册: 2005-09-30 11:08
帖子: 89
地址: 零陵
送出感谢: 0 次
接收感谢: 0 次
你是不是用了微软的一些字体,比如黑体,仿宋之类?
可能是这个问题。


_________________
A IP's Life for Me


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于emacs中显示中文标点符号的问题
帖子发表于 : 2010-02-24 19:09 
头像

注册: 2010-01-03 12:38
帖子: 1486
地址: 你他妈找死啊
送出感谢: 0 次
接收感谢: 0 次
:em11


_________________
    我希望我的心上人也能理解这一点,这一切的开始并不是为了什么价值、责任、过去或是未来,这一切甚至不是为了现在,这一切只是源于passion。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译