当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,Emacs, 奇怪的字体问题(中文字体和英文字体不能同时起作用)已解决。
帖子发表于 : 2007-07-23 14:20 

注册: 2006-09-20 19:56
帖子: 768
送出感谢: 0 次
接收感谢: 1
前两天从源里将emacs21换成了emacs22.1正式版,但字体设置出了问题。
只要把英文字体设成adobe courier, 中文字体就不起作用,只有换成fixed,中文字体(文泉驿)才起作用。
以下是我.emacs.el中关于字体设置的部分:
代码:
(create-fontset-from-fontset-spec
 (concat
  "-*-courier-medium-r-normal-*-14-*-*-*-*-*-fontset-myfontset,"
  "chinese-gb2312:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-gb2312*-*,"
  "mule-unicode-0100-24ff:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-iso10646*-*,"
  "mule-utf-8:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-iso10646*-*,"
  "korean-ksc5601:-*-*-medium-r-*-*-14-*-*-*-*-*-ksc5601*-*,"
  "chinese-cns11643-5:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-gbk*-*,"
  "chinese-cns11643-6:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-gbk*-*,"
  "chinese-cns11643-7:-*-wenquanyi bitmap song-medium-r-*-*-14-*-*-*-c-*-gbk*-*,"
  "sjis:-*-medium-r-normal--14-*-jisx0208*-*"))
(set-default-font "fontset-myfontset")
(setq default-frame-alist
      (append
       '((font . "fontset-myfontset")) default-frame-alist))


中文字体不起作用,如果将courier换成fixed,中文字体就起作用。
我用.Xdefaults进行设置,结果一样。
有谁知道解决方法,指点一下。

果然是由于7.10还不是稳定版的原因,今天升级了一堆东西,字体设置起作用了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译