[问题]关于Text Editor的Character Coding默认设置

Vim、Emacs配置和使用
回复
hitzq
帖子: 91
注册时间: 2006-12-19 0:42
送出感谢: 0
接收感谢: 0

[问题]关于Text Editor的Character Coding默认设置

#1

帖子 hitzq » 2007-08-23 10:07

为了正常显示中文,每次都要先打开Text Editor,在用File->Open->Character Coding里选择Chinese simplified(GBK)
怎样改成双击文件就默认使用Chinese simplified(GBK)
Preferences里面好像没有
zigzed
帖子: 267
注册时间: 2006-02-27 10:32
送出感谢: 0
接收感谢: 0

#2

帖子 zigzed » 2007-08-24 14:33

可以让gedit自动检测编码格式。

运行
gconf-editor

/apps/gedit-2/preferences/encodings/auto_detected
中加入 GB18030 就会自动检测 GBK/GB2312/GB18030编码的文件了。

为了识别 windows 下的unicode文件,也可以加入 UTF-16
yuffey
帖子: 193
注册时间: 2007-09-06 16:24
来自: 中国上海
送出感谢: 0
接收感谢: 0

#3

帖子 yuffey » 2007-10-22 9:45

好,已经设置。
zigzed 写了:可以让gedit自动检测编码格式。

运行
gconf-editor

/apps/gedit-2/preferences/encodings/auto_detected
中加入 GB18030 就会自动检测 GBK/GB2312/GB18030编码的文件了。

为了识别 windows 下的unicode文件,也可以加入 UTF-16
回复

回到 “Vim和Emacs”