[问题]vim 有时候打开文件巨慢,有时候还报错

Vim、Emacs配置和使用
回复
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

[问题]vim 有时候打开文件巨慢,有时候还报错

#1

帖子 sunzhaoyu2000 » 2007-09-09 11:23

有时候要等好几秒才能打开

有一次没有打开,报错如下
ICE default IO error handler doing an exit(), pid = 29668, errno = 4


请问怎样能解决这个问题?
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

#2

帖子 kinglead » 2007-11-13 22:27

我也碰到这个问题,楼主解决了吗?
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

#3

帖子 kinglead » 2007-11-14 8:43

我现在用konsole来代替原来的终端,打开文件时快多了,不知道什么原因,暂且先这么用着了.
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#4

帖子 windwiny » 2007-11-14 11:02

看一下 ~/.vimrc 之类的
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

#5

帖子 kinglead » 2007-11-14 19:50

我的.vimrc原来是没有的,后来配置了一下,现在在konsole下有时还是会出现卡,用vi的时候有时也会等3,5秒,不过比在gnome自带的终端下好些.
以下是我的.vimrc

代码: 全选

set nocompatible   "set file compatible
set hls         "set hight light
set showmatch
set tabstop=4
set history=1000
set autoindent
set incsearch
set nobackup
"set fileencodings=gbk
"et termencoding=gbk

"colorscheme elflord

syntax on
filetype on
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#6

帖子 windwiny » 2007-11-16 23:14

还有 .viminfo ,看看这文件多大,删掉
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

#7

帖子 sunzhaoyu2000 » 2007-11-17 21:56

知道问题所在:
断网的时候vim出错
nautinous打不开等等

网络一好
全部解决
不知所以
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

已解决问题,不过不知道这个文件是什么东西.

#8

帖子 kinglead » 2007-11-17 23:50

感谢楼上windwiny和楼主的解答,不过我的好像不是这个问题.
晚上试了一下,切换到root时用vim打开文件没有任何问题,速度非常快,而在我的普通用户下,打开一个文件至少要3秒以下,有时将近10秒,也有时非常快,于是想到可能两个用户下的某个文件在捣鬼,于是在普通用户下建一个文件夹lost,把所有隐藏文件都移动到这个文件夹里,再用vim打开文件,一切正常,于是开始地毯式搜索,先移动一部分文件,再来试vim的打开速度,最后只剩下了7,8个隐藏文件,于是一个一个移,移动了一个.ICEauthority 后,vim打开正常,心里狂喜,把这个文件移到lost里,再把别的移动回来,再用vim,OK,一切正常.
提醒楼主看一下是否也有这个文件,和我的是否一样的情况.
如果有别的兄弟也有同样的问题可以参考参考.
另外,哪位知道这个文件是做什么用的,为什么产生的,也请告知一下啊.
kinglead
帖子: 21
注册时间: 2007-11-13 15:54
送出感谢: 0
接收感谢: 0

我晕了

#9

帖子 kinglead » 2007-11-18 0:02

现在问题是解决了,可是还是很不明白.我重启X后,那个文件又产生了,我把原来的再拷贝回去,再用vim,居然又不出问题了,速度也很正常,到底是怎么回事呢.晕啊
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

#10

帖子 sunzhaoyu2000 » 2007-11-19 10:39

这个问题是很诡异

不过使用7.10就没有这个问题了
呵呵不用细想,能用就行
stone2083
帖子: 2
注册时间: 2008-01-17 10:20
送出感谢: 0
接收感谢: 0

#11

帖子 stone2083 » 2008-01-17 10:26

7.10下也同样存在这个问题。
估计是升级了什么软件有关,前几天还是正常的,昨天开始就遇到类似问题。

一旦删除.ICEauthority文件,就一切正常。
只要有这个文件,打开终端或者用vim打开文件,速度都特别慢。甚至还报:ice default io error.....

特别想知道.ICEauthority文件是干嘛用的。
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#12

帖子 roylez » 2008-01-17 12:07

你的问题我不知道怎么回事,你可以google。但是我记得filetype on要放在syntax on之前的。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#13

帖子 eexpress » 2008-01-17 23:23

怎么会和终端还有关哦。那你试试其他终端?
● 鸣学
stone2083
帖子: 2
注册时间: 2008-01-17 10:20
送出感谢: 0
接收感谢: 0

#14

帖子 stone2083 » 2008-02-25 12:51

怀疑是gnome的问题。后来做了一次升级,就没再出现类似问题。
回复

回到 “Vim和Emacs”