Emacs Problem

Vim、Emacs配置和使用
回复
mesocool
帖子: 113
注册时间: 2005-03-27 17:11
系统: Linux Mint 14 Nadia
来自: Seattle, USA
送出感谢: 0
接收感谢: 0
联系:

Emacs Problem

#1

帖子 mesocool » 2006-01-05 8:05

我装emacs之后,不显示文字,全是小方块,是不是因为改中文字体的原因亚,怎样设置才好呢,谢谢了。。
附件
Screenshot.png
头像
jaguar00
帖子: 227
注册时间: 2005-10-19 23:48
来自: 大山丛林
送出感谢: 0
接收感谢: 0

#2

帖子 jaguar00 » 2006-01-05 18:13

serach一下论坛关于emacs的文章,我记得有;应该和编码locale有关系。
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 duoxing » 2006-01-06 14:06

安装mule-ucs没有?
pluskid
帖子: 142
注册时间: 2005-11-05 23:18
送出感谢: 0
接收感谢: 1 次

#4

帖子 pluskid » 2006-01-14 13:57

emacs 的字体没有设置正确吧?
你按住shift在emacs里面点左键选一下字体试试。
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 duoxing » 2006-01-25 23:53

安装mule-ucs后,去下面的地址看看,里面关于字体方面的设置你复制过去应该可以解决了。
http://www.cduhacker.com/duoxing/?action=show&id=2
mesocool
帖子: 113
注册时间: 2005-03-27 17:11
系统: Linux Mint 14 Nadia
来自: Seattle, USA
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 mesocool » 2006-01-30 3:36

谢谢大家,最后在xorg里面加了点东西就好了,字体没有设置好。
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 yang119345 » 2006-02-07 11:17

首先安装mule-ucs
sudo apt-get install mule-ucs

emacs中文环境设置
ubuntu 5.10(emacs v21.4.1)
gedit ~/.emacs
然后添加以下代码
(set-language-environment 'Chinese-GB)
(set-keyboard-coding-system 'euc-cn)
(set-clipboard-coding-system 'euc-cn)
(set-terminal-coding-system 'euc-cn)
(set-buffer-file-coding-system 'euc-cn)
(set-selection-coding-system 'euc-cn)
(modify-coding-system-alist 'process "*" 'euc-cn)
(setq default-process-coding-system '(euc-cn . euc-cn))(setq-default pathname-coding-system 'euc-cn)


字体设置参考
about7360.html
附件
emacs.png
回复

回到 “Vim和Emacs”