当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : emacs在gnome下不能用XIM输入法(例如scim和fcitx)输入中文
帖子发表于 : 2006-01-06 23:06 

注册: 2006-01-06 22:55
帖子: 556
送出感谢: 0 次
接收感谢: 0 次
系统:Ubuntu5.10
我装了apt源中的emacs21和mule-ucs,CTRL-SPACE已经unset了,可以确定emacs本身是支持XIM中文输入的,因为在“安全终端”下面可以用scim、fcitx输入中文,但是在“gnome”或者“gnome安全模式”下面都不能输入中文,可以断定问题是在“gnome”。
有谁对“gnome”研究比较深,帮忙分析一下原因!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-01-07 17:54 
头像

注册: 2005-09-27 18:24
帖子: 498
地址: 杭州
送出感谢: 0 次
接收感谢: 0 次
你的断言,,,,

M-x global-unset-key 后可以吗?


页首
 用户资料  
 
3 楼 
 文章标题 : 之前已经unset了
帖子发表于 : 2006-01-07 20:04 

注册: 2006-01-06 22:55
帖子: 556
送出感谢: 0 次
接收感谢: 0 次
yangcheng 写道:
你的断言,,,,

M-x global-unset-key 后可以吗?

之前已经unset了,还是没反应,就是用鼠标点输入法也不行,但是在“安全终端”里确工作正常


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-01-09 5:15 
头像

注册: 2005-12-19 6:38
帖子: 117
地址: 德国
送出感谢: 0 次
接收感谢: 0 次
装上mule-ucs以后emacs启动慢了很多。况且装上了也不能在emacs里输入中文,又卸载了。 :?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-01-09 15:41 

注册: 2006-01-06 22:55
帖子: 556
送出感谢: 0 次
接收感谢: 0 次
lazyquail 写道:
装上mule-ucs以后emacs启动慢了很多。况且装上了也不能在emacs里输入中文,又卸载了。 :?

至少可以显示了,可以试试KDE中行不行


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-01-09 20:41 
头像

注册: 2005-12-19 6:38
帖子: 117
地址: 德国
送出感谢: 0 次
接收感谢: 0 次
:) 据说emacs23中文支持很好,等正式版发布了准备装那个。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译