Emacs下用Auctex + preview-latex的问题

Vim、Emacs配置和使用
回复
hardegg
帖子: 34
注册时间: 2006-01-03 17:00
送出感谢: 0
接收感谢: 0

Emacs下用Auctex + preview-latex的问题

#1

帖子 hardegg » 2006-01-09 21:25

安装了最新的auctex,里面包括了preview-latex包
我现在想直接在Emacs窗口中输出某个region的预览,而不是探出另一个预览窗口。但每次都不成功,会出现一大堆的错误提示,主要的部
分应该是:

Preview-Latex finished with nothing to show
LaTeX: LaTeX found no preview images

我查阅过很多帖子,似乎安装的过程都很正常,为什么会出现这个问题
难道是ubuntu的问题
大家有过这方面的经验么,帮帮忙,急~~
hardegg
帖子: 34
注册时间: 2006-01-03 17:00
送出感谢: 0
接收感谢: 0

#2

帖子 hardegg » 2006-01-10 9:47

没有人遇到过这个问题么?
brainy
帖子: 22
注册时间: 2006-01-02 13:11
送出感谢: 0
接收感谢: 0

#3

帖子 brainy » 2006-02-08 11:30

是不是emacs不支持图片?好像是ubuntu下默认安装的emacs没有编译进支持图片的功能吧。我也遇见这个问题。但是不想折腾了。
头像
notwind
帖子: 20
注册时间: 2005-12-05 19:25
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 notwind » 2006-02-27 23:02

在.emacs中加入

;; turn on image file support
(auto-image-file-mode)

试一下看看有没有用
brainy
帖子: 22
注册时间: 2006-01-02 13:11
送出感谢: 0
接收感谢: 0

#5

帖子 brainy » 2006-03-02 22:13

不行,说是没有找到image files
notwind 写了:在.emacs中加入

;; turn on image file support
(auto-image-file-mode)

试一下看看有没有用
头像
alinmn
帖子: 185
注册时间: 2006-05-19 21:42
来自: NIT
送出感谢: 0
接收感谢: 0

#6

帖子 alinmn » 2006-05-20 15:10

目前我也遇到过这种情况,发现一个特别奇怪的问题,就是把文档中的注释全部去掉后就好了,加上去后就又不行了。
duoxing
帖子: 122
注册时间: 2005-12-20 21:26
来自: UESTC
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 duoxing » 2006-05-20 22:31

关于图片的问题加入一个图片的插件试试,(可以肯定的就是emacs肯定支持图片显示的)就是支持w3m里面显示图片的那个插件,然后在加入上面的代码试试。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 zhan » 2006-05-25 22:33

不是图片这样的问题,我发现,有些即使没有图片的tex文档只要有很多注释的话就会有问题。现在去掉注释后是没有问题的。比较奇怪的说。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
roderic
帖子: 36
注册时间: 2007-11-23 21:31
送出感谢: 0
接收感谢: 0

Re: Emacs下用Auctex + preview-latex的问题

#9

帖子 roderic » 2009-01-08 23:13

An outdated ‘preview’ installation

The ‘preview.sty’ package is useful for more than just preview-latex. For example, it is part of TeXlive. So you have to make sure that preview-latex does not get to work with outdated style and configuration files: some newer features will not work with older TeX style files, and really old files will make preview-latex fail completely. There usual is a local ‘texmf’ tree, or even a user-specific tree that are searched before the default tree. Make sure that the first version of those files that gets found is the correct one.
mathematica
帖子: 13
注册时间: 2010-08-15 10:33
送出感谢: 0
接收感谢: 0

Re: Emacs下用Auctex + preview-latex的问题

#10

帖子 mathematica » 2013-03-09 22:27

遇到同样问题了。。。 :em06
lhui
帖子: 78
注册时间: 2009-09-04 16:42
送出感谢: 1 次
接收感谢: 5 次

Re: Emacs下用Auctex + preview-latex的问题

#11

帖子 lhui » 2013-03-10 20:54

是 AUCTeX 的问题。把 preview.el 中的

代码: 全选

(defcustom preview-gs-options '("-q" "-dSAFER" "-dNOPAUSE"
改成

代码: 全选

(defcustom preview-gs-options '("-q" "-dNOSAFER" "-dNOPAUSE"
然后重新编译一下,覆盖原有的 preview.elc
mathematica
帖子: 13
注册时间: 2010-08-15 10:33
送出感谢: 0
接收感谢: 0

Re: Emacs下用Auctex + preview-latex的问题

#12

帖子 mathematica » 2013-03-10 22:44

lhui 写了:是 AUCTeX 的问题。把 preview.el 中的

代码: 全选

(defcustom preview-gs-options '("-q" "-dSAFER" "-dNOPAUSE"
改成

代码: 全选

(defcustom preview-gs-options '("-q" "-dNOSAFER" "-dNOPAUSE"
然后重新编译一下,覆盖原有的 preview.elc


已尝试,问题如故,没有解决。。。

代码: 全选

Preview-LaTeX exited as expected with code 1 at Sun Mar 10 22:41:04
LaTeX: LaTeX found no preview images
mathematica
帖子: 13
注册时间: 2010-08-15 10:33
送出感谢: 0
接收感谢: 0

Re: Emacs下用Auctex + preview-latex的问题

#13

帖子 mathematica » 2013-03-10 22:48

lhui 写了:是 AUCTeX 的问题。把 preview.el 中的

代码: 全选

(defcustom preview-gs-options '("-q" "-dSAFER" "-dNOPAUSE"
改成

代码: 全选

(defcustom preview-gs-options '("-q" "-dNOSAFER" "-dNOPAUSE"
然后重新编译一下,覆盖原有的 preview.elc
我是在软件中心里直接安装的auctex,想要preview的话,除了auctex还需要装别的什么package吗?
mathematica
帖子: 13
注册时间: 2010-08-15 10:33
送出感谢: 0
接收感谢: 0

Re: Emacs下用Auctex + preview-latex的问题

#14

帖子 mathematica » 2013-03-12 21:04

lhui 写了:是 AUCTeX 的问题。把 preview.el 中的

代码: 全选

(defcustom preview-gs-options '("-q" "-dSAFER" "-dNOPAUSE"
改成

代码: 全选

(defcustom preview-gs-options '("-q" "-dNOSAFER" "-dNOPAUSE"
然后重新编译一下,覆盖原有的 preview.elc


已经解决,感谢!
回复

回到 “Vim和Emacs”