当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]打开gvim后,输入出现乱码,怎么解决?
帖子发表于 : 2007-12-04 23:57 

注册: 2007-11-26 20:32
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
菜鸟弱问:用sudo apt-get install vim-full装完gvim后,打开gvim后往里输入字符总是与输出的字符ascii码差1,比如在键盘上打i,屏幕上出现j,在键盘上打j,屏幕上出现k……
在终端上会有以下信息:
** (gvim:6589): CRITICAL **: ascii_glyph_table_init: assertion `gui.ascii_glyphs->num_glyphs == sizeof(ascii_chars)' failed

这是为什么?怎么解决?谢谢了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:53 

注册: 2007-11-01 14:27
帖子: 39
地址: 西北工业大学
送出感谢: 0 次
接收感谢: 0 次
/usr/share/vim/下,找到gvimrc并去掉如下几行的注释:

if has('gui_gtk2')

set guifont=Sans

else

set guifont=-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1

endif


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-08 8:56 
头像

注册: 2007-04-06 6:37
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
nwpu043793 写道:
/usr/share/vim/下,找到gvimrc并去掉如下几行的注释:

if has('gui_gtk2')

set guifont=Sans

else

set guifont=-misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1

endif

我也有阿,用楼上的方法还是不行


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-08 13:24 
头像

注册: 2007-09-11 21:51
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
在./.vimrc中添加
"设置GVIM正确显示英文
if has("gui")
set guifont=Courier\ 10\ Pitch\ 10
endif


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译