[问题]新装的系统内置的Gcc是不是不能直接用

C、C++和Java语言
回复
anzi
帖子: 3
注册时间: 2008-01-19 19:44
送出感谢: 0
接收感谢: 0

[问题]新装的系统内置的Gcc是不是不能直接用

#1

帖子 anzi » 2008-02-28 15:43

在虚拟机下新装的Unbutu7.10,用gcc -v 命令查看gcc的版本为4.1.3,但在运行Hello程序时出现如下错误:
test.c:1:18:error:stdio.h:No such file or directory
test.c:In function 'main'
test.c:4:warning: incompatible implict declaration of built-in function 'printf'
是不是新装的系统中没有glibc 、bunutils
如果有,那上面的问题是上面原因,怎么看他们的版本之类的一些基本信息
如果没有,安装那些版本的比较好,谢谢!
刚刚接触linux和gcc,请大家多多指教,再次谢谢!!!
anzi
帖子: 3
注册时间: 2008-01-19 19:44
送出感谢: 0
接收感谢: 0

#2

帖子 anzi » 2008-02-28 16:09

在dekula写的gcc error这个帖子中解决了这个问题

原来是没有安装C/C++的库

sudo apt-get install build-essential

就好了。
回复

回到 “C/C++/Java”