当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 紧急求助:终端不能运行命令,提示找不到libc.so.6
帖子发表于 : 2008-03-17 23:49 

注册: 2007-11-30 11:58
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
但是我的lib目录下面明明有这个文件阿


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-18 0:12 
头像

注册: 2007-06-13 11:32
帖子: 224
送出感谢: 0 次
接收感谢: 0 次
/lib下的libc.so.6应该是个链接文件,我的机子执行如下命令,结果如下:

代码:
desktop:/lib$ ls libc.so* -ali
1657 lrwxrwxrwx 1 root root 13 2007-12-22 21:03 libc.so.6 -> libc-2.6.1.so


libc.so.6链接到libc-2.6.1.so,你缺少的是这个文件吧!!

我的系统是ubuntu7.10,要不上传一个?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-20 14:26 
头像

注册: 2007-08-17 13:00
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
下载一个吧
网上找下,应该有lib的包


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-21 18:39 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
ldd 程序名字
贴出输出


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-21 22:07 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
应该是ln的。不需要ldd吧。或者,至少ldd xxx|grep libc6这样贴了。要不没边的。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译