当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装JDK 6 Update 6 with NetBeans 6.0.1问题
帖子发表于 : 2008-04-28 19:49 

注册: 2007-07-19 11:03
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我的系统是ubuntu8.04,我在Sun官方下载了JDK 6 Update 6 with NetBeans 6.0.1 Linux版的,文件名:jdk-6u6-nb-6_0_1-linux-ml.sh ,执行过 sudo chmond 775 jdk-6u6-nb-6_0_1-linux-ml.sh 后,我用两种帐户安装,安装都失败!错误信息略有不同见下面。他们都停留在图片无标题1.jpg,我点关闭安扭,第一种安装方式的提示是图片无标题2.jpg,第二种安装方式的提示是图片无标题3.jpg,请各位指点,先谢过!

zhiyuan@zhiyuan:/home/software$ sudo ./jdk-6u6-nb-6_0_1-linux-ml.sh
正在配置安装程序...
正在搜索系统上的 JVM...
正在准备捆绑的 JVM...
正在解压缩安装数据...
正在运行安装程序向导...
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb75c2767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb75c28b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0x983aa1bd]
#3 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x9849dd7e]
#4 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98487d47]
#5 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98487ec3]
#6 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26) [0x98488106]
#7 [0xb29e1bfa]
#8 [0xb29dbb3b]
#9 [0xb29dbb3b]
#10 [0xb29d9219]
#11 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb77752bc]
#12 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb7889f98]
#13 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb77750ef]
#14 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb77d2b9d]
#15 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb756f30d]
#16 [0xb29e14ab]
#17 [0xb29dba64]
#18 [0xb29d9219]
#19 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb77752bc]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb75c2767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb75c281e]
#2 /usr/lib/libX11.so.6 [0x983a9518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0x983a00a6]
#4 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98487089]
#5 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x984872d3]
#6 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98487f71]
#7 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26) [0x98488106]
#8 [0xb29e1bfa]
#9 [0xb29dbb3b]
#10 [0xb29dbb3b]
#11 [0xb29d9219]
#12 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb77752bc]
#13 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb7889f98]
#14 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so [0xb77750ef]
#15 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb77d2b9d]
#16 /tmp/.nbi-1045547.tmp/_jvm/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb756f30d]
#17 [0xb29e14ab]
#18 [0xb29dba64]
#19 [0xb29d9219]

以下是su root后
root@zhiyuan:/home/software# ./jdk-6u6-nb-6_0_1-linux-ml.sh
正在配置安装程序...
正在搜索系统上的 JVM...
正在准备捆绑的 JVM...
正在解压缩安装数据...
正在运行安装程序向导...
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7673767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb76738b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0x983451bd]
#3 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98438d7e]
#4 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98422d47]
#5 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98422ec3]
#6 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26) [0x98423106]
#7 [0xb2a8ebfa]
#8 [0xb2a88b3b]
#9 [0xb2a88b3b]
#10 [0xb2a86219]
#11 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb78222bc]
#12 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb7936f98]
#13 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb78220ef]
#14 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb787fb9d]
#15 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb761c30d]
#16 [0xb2a8e4ab]
#17 [0xb2a88a64]
#18 [0xb2a86219]
#19 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb78222bc]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7673767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb767381e]
#2 /usr/lib/libX11.so.6 [0x98344518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0x9833b0a6]
#4 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98422089]
#5 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x984222d3]
#6 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so [0x98422f71]
#7 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x26) [0x98423106]
#8 [0xb2a8ebfa]
#9 [0xb2a88b3b]
#10 [0xb2a88b3b]
#11 [0xb2a86219]
#12 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb78222bc]
#13 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb7936f98]
#14 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so [0xb78220ef]
#15 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb787fb9d]
#16 /tmp/.nbi-1043018.tmp/_jvm/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb761c30d]
#17 [0xb2a8e4ab]
#18 [0xb2a88a64]
#19 [0xb2a86219]
/usr/share/themes/Human/gtk-2.0/gtkrc:43: error: lexical error or unexpected token, expected valid token
root@zhiyuan:/home/software#


附件:
3.jpg
3.jpg [ 8.31 KiB | 被浏览 2719 次 ]
2.jpg
2.jpg [ 5.78 KiB | 被浏览 2720 次 ]
1.jpg
1.jpg [ 11.5 KiB | 被浏览 1451 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-01 13:35 
头像

注册: 2007-11-29 18:43
帖子: 28
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
偶是在新立得里面装的netbeasn和JDK
很好


_________________
偶们走快走慢
也赶不上地老天荒


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-02 2:24 

注册: 2008-05-01 23:23
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我是在官网上下载的6。1,安装的时候也有问题,我的JDK 是信里的de JRE5和JRE6
#9 [0xb2609b3b]
#10 [0xb2609b3b]
#11 [0xb2607219]
#12 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c42bc]
#13 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb78d8ed8]
#14 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so [0xb77c40ef]
#15 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x32d) [0xb7821b9d]
#16 /usr/lib/jvm/java-1.5.0-sun-1.5.0.15/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb75bb30d]
#17 [0xb260f4bb]
#18 [0xb2609a64]
#19 [0xb2607219]
/usr/share/themes/Human/gtk-2.0/gtkrc:43: error: lexical error or unexpected token, expected valid token


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-02 9:06 

注册: 2007-07-19 11:03
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
请高手帮忙 指点了 ,谢谢了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-03 10:19 
头像

注册: 2007-12-16 0:45
帖子: 275
送出感谢: 0 次
接收感谢: 0 次
你用sudo运行一下试试。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-08 22:08 

注册: 2008-05-06 15:17
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
用新得力安装吧,那个问题少些


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-08 23:19 
头像

注册: 2006-08-18 20:31
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
/usr/share/themes/Human/gtk-2.0/gtkrc:43: error: lexical error or unexpected token, expected valid token
的错误一般似乎是Java Runtime的版本太低所引起的,
使用 sudo update-alternatives --config java ,设置系统默认运行的runtime为 java 6,然后在安装NetBeans


_________________
我的征途是星辰大海

Cloudy PhD Student: http://cloudyphd.blogspot.com/
螺旋进化: http://helixevolution.wordpress.com/


最后由 Alpha.Roc 编辑于 2008-11-09 14:05,总共编辑了 1 次

页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-11 21:03 

注册: 2008-06-11 20:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
试试这个:System(系统) --> Preferences(首选项)--> Appearance(外观) --> Visual Effects(视觉效果), 选择 none(无).


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-19 1:05 

注册: 2008-06-19 1:00
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
follow 2 steps below then it can work :

1. change the libmawt.so file, if ur machine is not amd64, just change to i386 instead (u may installed more than 1 jvm, modify all of them if needed)
$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-1.5.0-sun/jre/lib/amd64/xawt/libmawt.so

2. turn off the visual effect

now , it works, right ?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-25 21:20 

注册: 2008-06-25 21:17
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
好像是中文字体问题
我也遇到过
拷个中文字体文件 如宋体
到jre的lib fonts下
就可以了

搜一下有很多解决方法


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-07-20 11:02 
头像

注册: 2008-07-19 21:13
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
:shock: 在 win 下找个 字体文件 , 然后把 JDK 的字体文件改成 win 下找到的那个就OK 了 。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-08-01 22:43 

注册: 2007-07-22 14:50
帖子: 99
地址: 哈尔滨工业大学
送出感谢: 0 次
接收感谢: 0 次
flotilla 写道:
试试这个:System(系统) --> Preferences(首选项)--> Appearance(外观) --> Visual Effects(视觉效果), 选择 none(无).
高人,我的视觉效果如果打开的话,好多java程序的界面都显示不出来,哈哈,终于找到病因了


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [问题]安装JDK 6 Update 6 with NetBeans 6.0.1问题
帖子发表于 : 2009-08-27 16:02 

注册: 2009-08-13 22:22
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
谢谢8楼楼主,我改了一下视觉效果也可以了,我想问一下:如何使英文界面变成中文界面


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [问题]安装JDK 6 Update 6 with NetBeans 6.0.1问题
帖子发表于 : 2010-01-10 13:16 

注册: 2010-01-10 9:54
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
:em01 正在学习中!!


_________________
牙齿黄


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译