当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]无法安装安装build-essential这个包
帖子发表于 : 2008-05-16 14:52 

注册: 2008-04-17 18:04
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.6) 但是 1.14.5ubuntu16 正要被安装
E: 无法安装的软件包


系统7.10,中科大的源

貌似依赖的软件包,在源里不全。。
有解决办法吗?(换源就算了)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-16 15:06 

注册: 2007-11-29 0:10
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
基本的linux包知识(包括deb和rpm包都是)
安装某些包的时候都可能出现依赖不满足的情况,可以自己下载要求依赖的包先安装,在安装现在的包

方便的方法是如果可以上网用apt方法安装保证最新最好,
或者使用dpkg命令安装deb包的时候,加上某个参数(忘记是什么),可以自动下载需要的包。


_________________
追求IT的自由,追求人生自由!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-16 15:08 

注册: 2007-11-29 0:10
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
将你的安装盘放进去,使用apt,一般也能够安装好build-essential的,
貌似8。04可以,以前用7。10好像盘上没有


_________________
追求IT的自由,追求人生自由!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-16 17:21 

注册: 2008-04-17 18:04
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
我如果能上外网,早换源了,也就不会发帖问了
希望哪位大大
能给个这个包的下载地址
谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译