当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]ubuntu8.04编程环境设置
帖子发表于 : 2008-05-27 22:00 

注册: 2007-12-13 17:22
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
在按照论坛帖子所述进行操作时遇到了问题,原帖:http://forum.ubuntu.org.cn/viewtopic.php?t=40971

具体问题:执行sudo apt-get install build-essential时:出现如下提示:
root@jun-laptop:/# apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential: Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.1.1) but it is not going to be installed
Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed

E: Broken packages

提示说需要安装 libc6-dev,于是运行:apt-get install libc6-dev
root@jun-laptop:/# apt-get install libc6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.5-0ubuntu14) but 2.7-10ubuntu3 is to be installed
E: Broken packages

提示说: libc6-dev: Depends: libc6 (= 2.5-0ubuntu14) but 2.7-10ubuntu3 is to be installed

现在不知道该如何办是好。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-07 22:08 

注册: 2007-05-31 20:54
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
n the console, type:

sudo aptitude update
sudo aptitude install build-essential

Good luck!


页首
 用户资料  
 
3 楼 
 文章标题 : 我们的问题一样
帖子发表于 : 2008-07-05 17:06 
头像

注册: 2008-07-05 15:02
帖子: 8
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
按照2楼的指示会出现如下:
sudo aptitude update
Hit http://opensource.nchc.org.tw feisty Release.gpg
Ign http://opensource.nchc.org.tw feisty/main Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty/multiverse Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty/restricted Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty/universe Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty-backports Release.gpg
Ign http://opensource.nchc.org.tw feisty-backports/main Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-backports/multiverse Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-backports/restricted Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-backports/universe Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty-proposed Release.gpg
Ign http://opensource.nchc.org.tw feisty-proposed/main Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-proposed/multiverse Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-proposed/restricted Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-proposed/universe Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty-security Release.gpg
Ign http://opensource.nchc.org.tw feisty-security/main Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-security/multiverse Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-security/restricted Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-security/universe Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty-updates Release.gpg
Ign http://opensource.nchc.org.tw feisty-updates/main Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-updates/multiverse Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-updates/restricted Translation-zh_CN
Ign http://opensource.nchc.org.tw feisty-updates/universe Translation-zh_CN
Hit http://opensource.nchc.org.tw feisty Release
Hit http://opensource.nchc.org.tw feisty-backports Release
Hit http://opensource.nchc.org.tw feisty-proposed Release
Hit http://opensource.nchc.org.tw feisty-security Release
Hit http://opensource.nchc.org.tw feisty-updates Release
Hit http://opensource.nchc.org.tw feisty/main Packages
Hit http://opensource.nchc.org.tw feisty/multiverse Packages
Hit http://opensource.nchc.org.tw feisty/restricted Packages
Hit http://opensource.nchc.org.tw feisty/universe Packages
Hit http://opensource.nchc.org.tw feisty/main Sources
Hit http://opensource.nchc.org.tw feisty/multiverse Sources
Hit http://opensource.nchc.org.tw feisty/restricted Sources
Hit http://opensource.nchc.org.tw feisty/universe Sources
Hit http://opensource.nchc.org.tw feisty-backports/main Packages
Hit http://opensource.nchc.org.tw feisty-backports/multiverse Packages
Hit http://opensource.nchc.org.tw feisty-backports/restricted Packages
Hit http://opensource.nchc.org.tw feisty-backports/universe Packages
Hit http://opensource.nchc.org.tw feisty-backports/main Sources
Hit http://opensource.nchc.org.tw feisty-backports/multiverse Sources
Hit http://opensource.nchc.org.tw feisty-backports/restricted Sources
Hit http://opensource.nchc.org.tw feisty-backports/universe Sources
Hit http://opensource.nchc.org.tw feisty-proposed/main Packages
Hit http://opensource.nchc.org.tw feisty-proposed/multiverse Packages
Hit http://opensource.nchc.org.tw feisty-proposed/restricted Packages
Hit http://opensource.nchc.org.tw feisty-proposed/universe Packages
Hit http://opensource.nchc.org.tw feisty-proposed/main Sources
Hit http://opensource.nchc.org.tw feisty-proposed/multiverse Sources
Hit http://opensource.nchc.org.tw feisty-proposed/restricted Sources
Hit http://opensource.nchc.org.tw feisty-proposed/universe Sources
Hit http://opensource.nchc.org.tw feisty-security/main Packages
Hit http://opensource.nchc.org.tw feisty-security/multiverse Packages
Hit http://opensource.nchc.org.tw feisty-security/restricted Packages
Hit http://opensource.nchc.org.tw feisty-security/universe Packages
Hit http://opensource.nchc.org.tw feisty-security/main Sources
Hit http://opensource.nchc.org.tw feisty-security/multiverse Sources
Hit http://opensource.nchc.org.tw feisty-security/restricted Sources
Hit http://opensource.nchc.org.tw feisty-security/universe Sources
Hit http://opensource.nchc.org.tw feisty-updates/main Packages
Hit http://opensource.nchc.org.tw feisty-updates/multiverse Packages
Hit http://opensource.nchc.org.tw feisty-updates/restricted Packages
Hit http://opensource.nchc.org.tw feisty-updates/universe Packages
Hit http://opensource.nchc.org.tw feisty-updates/main Sources
Hit http://opensource.nchc.org.tw feisty-updates/multiverse Sources
Hit http://opensource.nchc.org.tw feisty-updates/restricted Sources
Hit http://opensource.nchc.org.tw feisty-updates/universe Sources
正在读取软件包列表... 完成
sudo aptitude install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成
The following packages are BROKEN:
dpkg libc6-dev
The following NEW packages will be automatically installed:
cpp-4.1 dpkg-dev g++ g++-4.1 gcc-4.1 gcc-4.1-base libmudflap0
libmudflap0-dev libstdc++6-4.1-dev linux-libc-dev patch
The following NEW packages will be installed:
build-essential cpp-4.1 dpkg-dev g++ g++-4.1 gcc-4.1 gcc-4.1-base
libmudflap0 libmudflap0-dev libstdc++6-4.1-dev linux-libc-dev patch
0 packages upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 11.7MB of archives. After unpacking 42.3MB will be used.
The following packages have unmet dependencies:
dpkg: Breaks: dpkg-dev (< 1.14.6) but 1.13.24ubuntu6 is to be installed.
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) but 2.7-10ubuntu3 is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
build-essential [Not Installed]
dpkg-dev [Not Installed]
g++ [Not Installed]
g++-4.1 [Not Installed]
gcc-4.1 [Not Installed]
libc6-dev [Not Installed]
libmudflap0-dev [Not Installed]
libstdc++6-4.1-dev [Not Installed]

Score is -9818

Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
Reading extended state information
Initializing package states... 完成
Building tag database... 完成


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-05 18:34 
头像

注册: 2008-07-05 15:02
帖子: 8
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.ph ... 166#828166五楼有解决方案,供大家参考


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译