[已解决]ubuntu8.04 java环境配置问题(不能启动eclipse3.3.2)

C、C++和Java语言
回复
opengloves
帖子: 2
注册时间: 2008-06-13 15:51
送出感谢: 0
接收感谢: 0

[已解决]ubuntu8.04 java环境配置问题(不能启动eclipse3.3.2)

#1

帖子 opengloves » 2008-06-21 0:59

ubuntu8.04下jdk环境变量配置
不想用sudo apt-get sun-java5-*

过程:
在http://java.sun.com/javase/downloads/index_jdk5.jsp下载了jdk1.5.0_15
安装到/usr/lib/jvm/jdk1.5.0_15下
sudo gedit /etc/profile
在文件最后更改如下:
export JAVA_HOME=/usr/lib/jvm/jdk1.5.0_15
export PATH=$JAVA_HOME/bin:$JAVA_HOME/jre/bin:$PATH
umask 022

怕出错,重启机器。
echo $JAVA_HOME正确
echo $PATH正确
但是java -version 出错

信息如下:
程序 'java' 已包含在以下软件包中:
* java-gcj-compat-headless
* openjdk-6-jre-headless
* cacao
* j2re1.4
* kaffe
* jamvm
* gij-4.1
* gij-4.2
* sablevm
试试:apt-get install <选定的软件包>
bash: java:找不到命令

请教了。谢谢
上次由 opengloves 在 2008-06-21 1:17,总共编辑 1 次。
opengloves
帖子: 2
注册时间: 2008-06-13 15:51
送出感谢: 0
接收感谢: 0

#2

帖子 opengloves » 2008-06-21 1:17

解决了。


cd /etc
chmod 777 profile
./profile

要运行一遍,以前没有运行……
OK
回复

回到 “C/C++/Java”