ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

C、C++和Java语言
回复
andy86
帖子: 4
注册时间: 2008-12-05 8:28
送出感谢: 0
接收感谢: 0

ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

#1

帖子 andy86 » 2008-12-05 8:54

希望大家帮忙,我现在在作毕业设计,时间比较紧。先谢谢!

刚装完的时候好像G++是能用的,我当时还编译了一个程序试了一下,可是这几天下了许多更新,把输入法也换成了FCITX,就出问题了。用G++不能编译,后来发现G++根本就没有装上,晕,不知道为什么。不多说废话,总之,最后归结到libc6-dev无法安装,导致了其他相关软件都无法安装。

下列软件包存在未满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.7-10ubuntu4) 但是 2.8~20080505-0ubuntu7 已安装

知道是版本匹配问题,上网找了N久,没找到可用的方法,源也换了N个,用过校园网的都知道下午和晚上的网速的,还有的是外国的源,慢的没话说。然而更令人痛心的是,更新完源后,问题依旧,要哭了。可是下不了重装的决心。

期待好心的Ubuntu人帮助,实在不行的话,就重装了。

PS:有作 linux下话音采集、压缩和传输的朋友,可以一起交流下。QQ:413582065
andy86
帖子: 4
注册时间: 2008-12-05 8:28
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

#2

帖子 andy86 » 2008-12-05 9:05

在线等。。。
andy86
帖子: 4
注册时间: 2008-12-05 8:28
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

#3

帖子 andy86 » 2008-12-05 14:35

郁闷,看来要重装了。。。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

Re: ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

#4

帖子 BigSnake.NET » 2008-12-05 21:05

通常是你的源设错了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
andy86
帖子: 4
注册时间: 2008-12-05 8:28
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04 libc6 和 libc6-dev不匹配,无法安装g++

#5

帖子 andy86 » 2008-12-09 14:34

BigSnake.NET 写了:通常是你的源设错了
谢谢回复,我已经重装了...现在可以用了 :em09
回复

回到 “C/C++/Java”