当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2008-12-12 13:50 

注册: 2007-09-08 16:21
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
run configure没有问题。
compiler file时出现:

cd '/home/seaboat/Desktop/hello/debug/src' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" LC_MESSAGES="C" LC_CTYPE="C" make -k hello.lo
/bin/bash ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I/home/seaboat/Desktop/hello/src -I.. -O0 -g3 -MT hello.lo -MD -MP -MF .deps/hello.Tpo -c -o hello.lo /home/seaboat/Desktop/hello/src/hello.cpp
../libtool: line 832: X--tag=CXX: command not found
../libtool: line 865: libtool: ignoring unknown tag : command not found
../libtool: line 832: X--mode=compile: command not found
../libtool: line 999: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 1000: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
../libtool: line 1143: Xg++: command not found
../libtool: line 1143: X-DHAVE_CONFIG_H: command not found
../libtool: line 1143: X-I.: command not found
../libtool: line 1143: X-I/home/seaboat/Desktop/hello/src: No such file or directory
../libtool: line 1143: X-I..: command not found
../libtool: line 1143: X-O0: command not found
../libtool: line 1143: X-g3: command not found
../libtool: line 1143: X-MT: command not found
../libtool: line 1143: Xhello.lo: command not found
../libtool: line 1143: X-MD: command not found
../libtool: line 1143: X-MP: command not found
../libtool: line 1143: X-MF: command not found
../libtool: line 1143: X.deps/hello.Tpo: No such file or directory
../libtool: line 1143: X-c: command not found
../libtool: line 1195: Xhello.lo: command not found
../libtool: line 1200: libtool: compile: cannot determine name of library object from `': command not found
make: *** [hello.lo] Error 1
*** Exited with status: 2 ***


有很多command not found
我是安装了libtool这个东东的, apt-get install X的时候,提示找不到package


选择build project后,出现:

cd '/home/seaboat/Desktop/hello/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" LC_MESSAGES="C" LC_CTYPE="C" make -k
make all-recursive
Making all in src
/bin/bash ../libtool --tag=CXX --mode=link g++ -O0 -g3 -o hello hello.o
../libtool: line 832: X--tag=CXX: command not found
../libtool: line 865: libtool: ignoring unknown tag : command not found
../libtool: line 832: X--mode=link: command not found
../libtool: line 999: *** Warning: inferring the mode of operation is deprecated.: command not found
../libtool: line 1000: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
gcc: no input files
gcc: no input files
gcc: no input files
gcc: no input files
../libtool: line 2237: X-O0: command not found
../libtool: line 2237: X-g3: command not found
../libtool: line 2406: Xhello: command not found
X: user not authorized to run the X server, aborting.
../libtool: line 2418: Xhello: command not found
../libtool: line 2426: mkdir /.libs: No such file or directory
mkdir: cannot create directory `/.libs': Permission denied
make[2]: *** [hello] Error 1
make[2]: Target `all' not remade because of errors.
make[2]: Nothing to be done for `all-am'.
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*** Exited with status: 2 ***


mkdir 无法创建文件夹? 权限?




完全搞不懂了。 :em20
望高手赐教! :em21


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-01-18 12:22 

注册: 2008-12-25 17:55
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
手动将工程目录下的/debug/libtool文件中的全部$echo替换为 $ECHO,工程可以编译成功


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-01-19 10:10 

注册: 2009-01-12 17:15
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
谢谢阿~ 我也碰到了这个问题,终于搞定了 :em05


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-02-11 14:29 

注册: 2009-02-11 14:26
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
将 /usr/bin/libtool拷到工程根目录及工程的debug目录下再次编译


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-03-09 15:22 

注册: 2008-09-28 0:43
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
1 复制目录 "/usr/share/apps/kdevappwizard/" to "$HOME/.kde/share/apps/
2 用这个文件进行替换$HOME/.kde/share/apps/kdevappwizard/template-common/incadmin.tar.gz


附件:
incadmin.tar.gz [87.98 KiB]
被下载 75 次
页首
 用户资料  
 
6 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-03-20 23:01 
头像

注册: 2008-11-13 0:37
帖子: 71
地址: SYSU_Guangzhou
送出感谢: 3
接收感谢: 0 次
hellowangmin 写道:
1 复制目录 "/usr/share/apps/kdevappwizard/" to "$HOME/.kde/share/apps/
2 用这个文件进行替换$HOME/.kde/share/apps/kdevappwizard/template-common/incadmin.tar.gz



楼主的方法行不通呀


_________________
life is what?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-03-25 22:31 

注册: 2008-11-14 20:35
帖子: 259
送出感谢: 0 次
接收感谢: 1
chunhuaxiaohan 写道:
手动将工程目录下的/debug/libtool文件中的全部$echo替换为 $ECHO,工程可以编译成功

这个方法可以,但是能不能让它自动修改呢?总不能每次都手动修改吧?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-04-03 20:41 

注册: 2009-04-03 20:20
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
将libtool换成低版本
libtool_1.5.26-1ubuntu1_i386.deb
http://ftp.sjtu.edu.cn/ubuntu/pool/m...untu1_i386.deb


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-04-18 21:53 
头像

注册: 2009-03-19 22:50
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,我也试试!


_________________
Shut down the windows,Let's share the free World!
西电稻草堂信息安全防护互助平台


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-04-18 22:01 
头像

注册: 2009-03-19 22:50
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
chunhuaxiaohan 写道:
手动将工程目录下的/debug/libtool文件中的全部$echo替换为 $ECHO,工程可以编译成功

感谢,支持,完全可用,立马见效,谢谢! :em02 :em05 :em11


_________________
Shut down the windows,Let's share the free World!
西电稻草堂信息安全防护互助平台


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-07-31 15:00 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
xdsn 写道:
chunhuaxiaohan 写道:
手动将工程目录下的/debug/libtool文件中的全部$echo替换为 $ECHO,工程可以编译成功

感谢,支持,完全可用,立马见效,谢谢! :em02 :em05 :em11

增加
代码:
echo=echo


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2009-11-30 12:09 
头像

注册: 2008-09-18 1:22
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
为什么可以编译了又不能运行了…… :em20


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 郁闷了,kdevelop连个helloworld都无法编译成功
帖子发表于 : 2010-07-30 15:50 

注册: 2009-10-15 16:51
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
1 复制目录 "/usr/share/apps/kdevappwizard/" to "$HOME/.kde/share/apps/
2 用这个文件进行替换$HOME/.kde/share/apps/kdevappwizard/template-common/incadmin.tar.gz

这个方法可以,只是需用自己系统里的文件


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译