当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在线求助 怎么样安装低版本的GCC
帖子发表于 : 2009-01-11 21:04 

注册: 2008-06-25 22:38
帖子: 15
送出感谢: 0 次
接收感谢: 1
求助:ubuntu8.10 32位,装了GCC4.3.2,发现总有问题,想换4.2.3,怎么操作 ? atp-get默认装的就是最高版本,新立德也只能看到最新版本。谢谢。 :em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 在线求助 怎么样安装低版本的GCC
帖子发表于 : 2009-01-11 21:45 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
herocock 写道:
求助:ubuntu8.10 32位,装了GCC4.3.2,发现总有问题,想换4.2.3,怎么操作 ? atp-get默认装的就是最高版本,新立德也只能看到最新版本。谢谢。 :em20


怎么可能没有呢? ubuntu 8.10 源中包含 gcc 3.4.6 4.1.2 4.2.4 4.3.2 四个版本
代码:
sudo apt-get install  gcc gcc-3.4 gcc-4.1 gcc-4.2 gcc-4.3


使用时即可直接

gcc-3.4 hello.c

也可以

gcc -V 3.4 hello.c

当然如果你愿意,也可以让gcc指向他们中任何一个


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 在线求助 怎么样安装低版本的GCC
帖子发表于 : 2009-01-11 21:54 

注册: 2008-06-25 22:38
帖子: 15
送出感谢: 0 次
接收感谢: 1
晕,为什么我的源里找不到,只有4.3.2的版本,请问楼上哪个源 ?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 在线求助 怎么样安装低版本的GCC
帖子发表于 : 2009-01-11 22:02 

注册: 2008-06-25 22:38
帖子: 15
送出感谢: 0 次
接收感谢: 1
reload一下,貌似看到了。谢谢哦。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译