当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Eclipse找不到标准头文件
帖子发表于 : 2006-06-25 21:28 
头像

注册: 2006-05-12 23:28
帖子: 621
地址: 江西乐平
送出感谢: 0 次
接收感谢: 1
昨天重装了一遍Ubuntu,自己下了个Eclipse3.2RC7,不知为何编译C++文件的时候出现类似这样的错误:
C/C++ Indexer Problem: Preprocessor Inclusion not found: iostream in file: /home/shiwl/EclipseWorkspace/DataStructure/ADTs/C01Introduction.h on line: 3.
看来是找不到像iostream之类的标准头文件。

我已经安装了build-essential等一些包。还需要怎样才能正常编译呢? :( 之前都没问题的……


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-06-26 20:33 
头像

注册: 2006-06-03 16:49
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
它给的是一些 warning。我的也是一样,可以编译通过。

不过我也不知道如何让 Eclipse 找到这些头文件。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-06-27 16:22 
头像

注册: 2006-06-03 16:49
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
哥们,试出一个方法。在 preprocessor 的设置里加上标准头文件的路径就可以了。
具体的方法如下:
Project->Properties->C++ Build->Tool Settings->GCC C++ Compiler->Directories
窗口里有一个小图标 Add。点它添加路径:/usr/include/c++/4.0.3

我的系统是 ubuntu 6.06。eclipse 是 3.1,软件库中的版本。如果你还不行就发帖再说


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-06-27 16:28 
头像

注册: 2006-06-03 16:49
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
忘了说了,上面的方法是每个项目都要设置一次。我也没办法一次性搞定。

如果哪位高手知道如何做也告诉我一下,学习~~~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-06-29 0:27 
头像

注册: 2006-05-12 23:28
帖子: 621
地址: 江西乐平
送出感谢: 0 次
接收感谢: 1
两天没来了…… :)
其实我之前用Eclipse都没有问题的,他都能自动帮我把标准库添加进去。这次重装系统之后不知为何就不好用了,源里的3.1.2根本没法用,每次启动之后之前的设置全部都找不到,添加Make Target也不正常。用下载来的3.2也不太正常,似乎对workspace有权限问题。总之我现在对Linux的基础知识了解太少了,不出问题还好,一出问题就没辙。

现在想尝试不用IDE,学高手们用Emacs或者VIM编程了。前天装Emacs也不太顺利。继续练吧…… :)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-06-29 10:22 
头像

注册: 2006-06-03 16:49
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
呵呵,咱们是一个状况


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-06-29 12:09 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
FFFrog 写道:
两天没来了…… :)
其实我之前用Eclipse都没有问题的,他都能自动帮我把标准库添加进去。这次重装系统之后不知为何就不好用了,源里的3.1.2根本没法用,每次启动之后之前的设置全部都找不到,添加Make Target也不正常。用下载来的3.2也不太正常,似乎对workspace有权限问题。总之我现在对Linux的基础知识了解太少了,不出问题还好,一出问题就没辙。

现在想尝试不用IDE,学高手们用Emacs或者VIM编程了。前天装Emacs也不太顺利。继续练吧…… :)



emacs怎么会不顺呢,呵呵。文本编辑那个版块有几篇帖子关于这个的,去看看把。


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-06-29 18:41 
头像

注册: 2006-05-12 23:28
帖子: 621
地址: 江西乐平
送出感谢: 0 次
接收感谢: 1
最开始按照置顶的帖子的方法自己cvs、编译emacs23,结果出来的东西不能用,在终端输入emacs后提示什么找不到数据库之类的东西(记不清楚了),自己不知道该用什么方法删除,就吧/usr/share/emacs和/usr/bin里的emacs链接都删除了。之后我用新立得装emacs21,结果居然出现包依赖错误,总是提示不能正常安装。记得当时是不能运行emacs的,但后来(一天后)有可以从终端运行了。但之后每次系统更新之后都会跟我说emacs、emacs21包依赖错误,感觉很烦,终于又把emacs21给删了……
当时的情况就是这样…… :shock:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译