Eclipse找不到标准头文件

C、C++和Java语言
回复
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

Eclipse找不到标准头文件

#1

帖子 FFFrog » 2006-06-25 21:28

昨天重装了一遍Ubuntu,自己下了个Eclipse3.2RC7,不知为何编译C++文件的时候出现类似这样的错误:
C/C++ Indexer Problem: Preprocessor Inclusion not found: iostream in file: /home/shiwl/EclipseWorkspace/DataStructure/ADTs/C01Introduction.h on line: 3.
看来是找不到像iostream之类的标准头文件。

我已经安装了build-essential等一些包。还需要怎样才能正常编译呢? :( 之前都没问题的……
头像
ydong
帖子: 63
注册时间: 2006-06-03 16:49
送出感谢: 0
接收感谢: 0

#2

帖子 ydong » 2006-06-26 20:33

它给的是一些 warning。我的也是一样,可以编译通过。

不过我也不知道如何让 Eclipse 找到这些头文件。
头像
ydong
帖子: 63
注册时间: 2006-06-03 16:49
送出感谢: 0
接收感谢: 0

#3

帖子 ydong » 2006-06-27 16:22

哥们,试出一个方法。在 preprocessor 的设置里加上标准头文件的路径就可以了。
具体的方法如下:
Project->Properties->C++ Build->Tool Settings->GCC C++ Compiler->Directories
窗口里有一个小图标 Add。点它添加路径:/usr/include/c++/4.0.3

我的系统是 ubuntu 6.06。eclipse 是 3.1,软件库中的版本。如果你还不行就发帖再说
头像
ydong
帖子: 63
注册时间: 2006-06-03 16:49
送出感谢: 0
接收感谢: 0

#4

帖子 ydong » 2006-06-27 16:28

忘了说了,上面的方法是每个项目都要设置一次。我也没办法一次性搞定。

如果哪位高手知道如何做也告诉我一下,学习~~~
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 FFFrog » 2006-06-29 0:27

两天没来了…… :)
其实我之前用Eclipse都没有问题的,他都能自动帮我把标准库添加进去。这次重装系统之后不知为何就不好用了,源里的3.1.2根本没法用,每次启动之后之前的设置全部都找不到,添加Make Target也不正常。用下载来的3.2也不太正常,似乎对workspace有权限问题。总之我现在对Linux的基础知识了解太少了,不出问题还好,一出问题就没辙。

现在想尝试不用IDE,学高手们用Emacs或者VIM编程了。前天装Emacs也不太顺利。继续练吧…… :)
头像
ydong
帖子: 63
注册时间: 2006-06-03 16:49
送出感谢: 0
接收感谢: 0

#6

帖子 ydong » 2006-06-29 10:22

呵呵,咱们是一个状况
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 zhan » 2006-06-29 12:09

FFFrog 写了:两天没来了…… :)
其实我之前用Eclipse都没有问题的,他都能自动帮我把标准库添加进去。这次重装系统之后不知为何就不好用了,源里的3.1.2根本没法用,每次启动之后之前的设置全部都找不到,添加Make Target也不正常。用下载来的3.2也不太正常,似乎对workspace有权限问题。总之我现在对Linux的基础知识了解太少了,不出问题还好,一出问题就没辙。

现在想尝试不用IDE,学高手们用Emacs或者VIM编程了。前天装Emacs也不太顺利。继续练吧…… :)

emacs怎么会不顺呢,呵呵。文本编辑那个版块有几篇帖子关于这个的,去看看把。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 FFFrog » 2006-06-29 18:41

最开始按照置顶的帖子的方法自己cvs、编译emacs23,结果出来的东西不能用,在终端输入emacs后提示什么找不到数据库之类的东西(记不清楚了),自己不知道该用什么方法删除,就吧/usr/share/emacs和/usr/bin里的emacs链接都删除了。之后我用新立得装emacs21,结果居然出现包依赖错误,总是提示不能正常安装。记得当时是不能运行emacs的,但后来(一天后)有可以从终端运行了。但之后每次系统更新之后都会跟我说emacs、emacs21包依赖错误,感觉很烦,终于又把emacs21给删了……
当时的情况就是这样…… :shock:
回复

回到 “C/C++/Java”