当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 问一个关于axel的问题[已解决]。
帖子发表于 : 2009-04-11 20:50 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
最近在研究axel。

源文件如下,gcc编译的命令是gcc -g -Wall axel_demo.c axel.c conf.c conn.c ftp.c http.c tcp.c -lpthread -o new_axel
没有任何错误。
然后,运行./new_axel http://code.google.com/p/gnome-menu-fil ... menu-bar.c panel-menu bar.c
结果Segmentation fault。

代码:
| 1#include <stdio.h>                                                             
| 2#include <string.h>                                                           
| 3#include "axel.h"                                                             
| 4                                                                               
| 5int main( int argc, char *argv[] )                                             
| 6{                                                                             
| 7     /* example: a.out url filename */                                         
| 8     conf_t *demo_conf_t_p;                                                   
| 9     axel_t *demo_axel_t_p = axel_new( demo_conf_t_p, 0, *( argv + 1 ) );     
|10     if( demo_axel_t_p == NULL )                                               
|11          printf( "WRONG: FAILED TO GET A NEW axel_t.\n" );                   
|12                                                                               
|13     strcpy( demo_axel_t_p->filename, *( argv + 2 ) );                         
|14                                                                               
|15     if( axel_open( demo_axel_t_p ) == 0 )                                     
|16          printf( "WRONG: FAILED AT axel_open()." );                           
|17                                                                               
|18     axel_start( demo_axel_t_p );                                             
|19                                                                               
|20     while( !( demo_axel_t_p->ready ) )                                       
|21     {                                                                         
|22          sleep( 2 );                                                         
|23          axel_do( demo_axel_t_p );                                           
|24     }                                                                         
|25                                                                               
|26     axel_close( demo_axel_t_p );                                             
|27                                                                               
|28     return 0;                                                                 
|29}


那是因为没有conn_init,还缺一个给conn_t malloc()一下的过程……


_________________
http://wecing.blogbus.com/->welcome


最后由 薰衣草的轨迹 编辑于 2009-04-11 23:29,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 20:54 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
gcc提示信息之一:
代码:
/home/lavender/idea/axel-1.1/axel_demo.c:9: undefined reference to `axel_new‘


所有的错误信息一共六行,
第一行是什么“在main函数里有错误”,
其余的五行与上面给出的类同,不过是另外几个函数的提示,比如axel_do之类的。都是在axel.h里面有函数原型的。


_________________
http://wecing.blogbus.com/->welcome


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 20:54 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
把头文件用绝对路径试下。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 20:59 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
没有一点变化。 :em20

嗯,顺便问个问题哈……
头文件里的函数原型对应的定义放在axel.c里面,可是axel.h里面根本就没有提到axel.c……
不过就算这样编译器应该也能找到定义吧。


_________________
http://wecing.blogbus.com/->welcome


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 21:01 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
函数里的参数好多空格! :em20


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 21:04 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
我选择,我喜欢,oh yeah。 :em04


_________________
http://wecing.blogbus.com/->welcome


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 21:26 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
等会,我好像有点明白了……
争取马上解决问题……


_________________
http://wecing.blogbus.com/->welcome


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 问一个关于#include的问题。
帖子发表于 : 2009-04-11 21:49 
头像

注册: 2008-07-07 11:16
帖子: 130
地址: 辽宁-大连
送出感谢: 0 次
接收感谢: 0 次
下回来的axel居然要先./configure以及make一下……(谁知道make是不是多余的……反正make install也弄了下……)

然后,
我,
很光荣地,
Segmentation fault了……


_________________
http://wecing.blogbus.com/->welcome


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译