当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 发现一个OmniCppComplete的bug!
帖子发表于 : 2006-07-30 15:36 

注册: 2006-07-30 15:30
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我用命令
代码:
ctags -R  --c++-kinds=+p --fields=+iaS --extra=+q  -f ~/.vim/systags /usr/include /usr/local/include

生成了系统api库和stl等的tag文件。


在vim中,可以对系统函数提示。
但是对于c++中的vector却没有提示。
我想这会不会是bug呢?
因为OmniCppComplete虽然不能对vector进行提示,却可以为string对象的成员方法进行提示。

有那位大侠遇到过这样的情况马?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-18 20:58 
头像

注册: 2007-04-03 9:52
帖子: 353
送出感谢: 0 次
接收感谢: 0 次
这个问题我也是写信问了作者才解决的


---------------------------------------------------------------------------------------------------
Hello,

Here is what I do, this solution works both for windows and unix system :

1) Download SGI's STL from SGI's site
( http://www.sgi.com/tech/stl/download.html)
2) With vim replace all __STL_BEGIN_NAMESPACE by "namespace std {" and
__STL_END_NAMESPACE by "}" (I use a macro to do this but maybe there
is a better way eg: the command :bufdo) from header and source files.
3) Run ctags and put the generated tags file in a directory eg:
~/MyTags/stl.tags
4) set tags+=~/MyTags/stl.tags

The main problem is that you can't tell to ctags that
__STL_BEGIN_NAMESPACE = "namespace std {" even with the option -I.
That's why you need the step 2).

Best regards,

Vissale


_________________
TODO LIST:
1.valgrind:
2.gcov:
3.cppuint:未在Linux中使用
4.PostgreSQL:unixODBC
5.Doxygen:UTF8 中文问题,生成LaTex文档问题
6.LaTex:明确安装问题,UTF8 中文字体问题


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译