当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请教CodeBlocks使用wxMediaCtrl配置问题
帖子发表于 : 2009-07-09 11:14 

注册: 2009-07-09 10:15
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
在win下搞了一媒体播放器,使用wx的wxMediaCtrl类,在win 下编译正常,但是在ubuntu9.04下老是提示未定义wxMediaCtrl。

这个应该跟wx库有关系,只是目前还没搞清楚。

各位给个意见,谢啦。

比如wxWidgets库的安装,CodeBlocks配置方面。

下面是测试代码,
#include <wx/mediactrl.h>

wxString info = _T("/var/www/1.mp3");

wxMediaCtrl* p_media = new wxMediaCtrl();
p_media->Create(this, wxID_ANY, wxEmptyString, wxDefaultPosition, wxDefaultSize, 0, wxMEDIABACKEND_GSTREAMER);
p_media->Load(info);
p_media->Play();
......

在p_media->Create()出错了,undefined reference to wxMediaCtrl::Create(....)

安装wxWidgets库的时候的命令:
sudo apt-get install libwxgtk2.8-0 libwxgtk2.8-dev wx2.8-headers wx-common


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请教CodeBlocks使用wxMediaCtrl配置问题
帖子发表于 : 2009-07-09 16:54 

注册: 2009-01-05 11:42
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
wxUSE_MEDIACTRL ???

或者编译时保留下预编译生成的文件,貌似 gcc --save-temps or --keep-temps 。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请教CodeBlocks使用wxMediaCtrl配置问题
帖子发表于 : 2009-07-09 17:42 

注册: 2009-07-09 10:15
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
谢谢 kamasamikon
不过我觉得应该不是 编译相关的问题,因为我是直接从 ubuntu source里update的

可能我的CodeBlocks的全局变量设置的又问题,不知你的怎么设置的?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译