当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-12 19:48 
头像

注册: 2008-09-01 0:12
帖子: 43
送出感谢: 1
接收感谢: 0 次
才新建一个C工程就马上出错
操作是这样的
file-->new-->C Project-->
project type选的是hello world ansi c project
toolchains 是默认linux gcc
然后点finish
直接跳出44个错误

各位高人指点啊


附件:
Screenshot.png
Screenshot.png [ 123.97 KiB | 被浏览 752 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-12 20:01 
头像

注册: 2009-07-07 19:52
帖子: 240
送出感谢: 0 次
接收感谢: 0 次
不用 eclipse 的飘过。如果确定代码没问题,那就应该是你的编译环境有问题,eclipse没设置正确。


_________________
阿呆 : 天下第一呆!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-12 20:22 
头像

注册: 2008-09-01 0:12
帖子: 43
送出感谢: 1
接收感谢: 0 次
linjiework 写道:
不用 eclipse 的飘过。如果确定代码没问题,那就应该是你的编译环境有问题,eclipse没设置正确。


还是不懂啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-12 21:01 

注册: 2008-11-15 8:43
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
我也新手,你先确定一下你的编写是否正确,我觉得应该是编写有问题吧

这是你第一次用gcc编译么?如果以前就用过gcc编译成功过,在没有更新系统的情况下,那就不应该是gcc的问题了。

不知道你是不是新手,如果是新手,eclipse对于新手来说有些难度。建议使用vim+gcc


页首
 用户资料  
 
5 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-12 21:05 
头像

注册: 2008-09-01 0:12
帖子: 43
送出感谢: 1
接收感谢: 0 次
wnwnwn 写道:
我也新手,你先确定一下你的编写是否正确,我觉得应该是编写有问题吧

这是你第一次用gcc编译么?如果以前就用过gcc编译成功过,在没有更新系统的情况下,那就不应该是gcc的问题了。

不知道你是不是新手,如果是新手,eclipse对于新手来说有些难度。建议使用vim+gcc


不是
关键是用eclipse的话就不用交叉编译了
交叉编译太难搞了
完全不明白

谢谢你


页首
 用户资料  
 
6 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-13 0:31 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
引用:
不是
关键是用eclipse的话就不用交叉编译了
交叉编译太难搞了
完全不明白

谢谢你

交叉编译和用不用 eclipse 没任何关系吧?
该交叉编译的,无论用不用ide,还是用哪个ide,都还是要交叉编译
不需要交叉编译的,不用ide还是不需要


页首
 用户资料  
 
7 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-08-13 9:44 
头像

注册: 2008-09-01 0:12
帖子: 43
送出感谢: 1
接收感谢: 0 次
周胜波 写道:
经过这几天查找各方面的资料,我得出的结论是:完全可以用Ubuntu搭建嵌入式环境

1.使用Minicom替代windows下的DNW

2.使用Eclipse+CDT+GUNARM可以配置出集成开发环境

3.使用JFlash烧写Flash

4.如果不使用集成开发环境,可以自己配置编译交叉编译链,一共5个包如下:

binutils------二进制实用工具
gcc----------建立arm-linux-gcc工具
glibc---------标准C库
glibc-linuxthreads--------glibc依赖
gdb----------调试工具

下载地址:ftp.gun.org

5.如果觉得自己编译麻烦可以使用Crosstool构建交叉编译链

如果大家有兴趣可以尝试一下,有什么心得一起分享,有时间我会写出完整的使用教程


viewtopic.php?f=97&p=1408409

我也是看的上面这个....


页首
 用户资料  
 
8 楼 
 文章标题 : Re: eclipse老出错,无法编译,高手指教[图]
帖子发表于 : 2009-09-18 9:34 

注册: 2008-08-15 10:11
帖子: 8
地址: 大连
送出感谢: 0 次
接收感谢: 0 次
:em03 你看看gcj和java好像在eclipse里面有冲突。我也出现了楼主的问题。卸载和gcj相关的包。我的就好了。楼主可以参考一下。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译