当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-10-31 22:51 

注册: 2009-06-08 21:32
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用的是ubuntu9.10新立得里的tomcat和eclipse.在eclipse-->Window-->Preferences-->Server Runtime environments 下配置tomcat6时
Tomcat installation directory设为/usr/share/tomcat6时报错“ The Tomcat installation directory is not valid. It is missing expected file or folder conf.”
Tomcat installation directory设为/usr/share/tomcat6/bin时或"/usr/share/tomcat6/bin"时报错" The Tomcat installation directory is not valid. It is missing expected file or folder lib/jasper-el.jar."
希望有配置成功的朋友给个详细的解决办法。最好有出错的原因..


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-10-31 22:59 

注册: 2009-06-08 21:32
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
希望我明天起床就可以解决问题了~~~ :em01


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-10-31 23:47 

注册: 2008-11-07 3:42
帖子: 289
送出感谢: 0 次
接收感谢: 0 次
难道是没安java?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-10-31 23:48 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
先whereis瞧下tomcat的可执行文件在哪,可能在/usr/bin下也难说。。。 :em06


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-01 0:07 

注册: 2009-06-08 21:32
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
mckeyu 写道:
难道是没安java?

Java那是先装了的.终端下也java -version了的.
tomcat也是OK的.http://localhost:8080也是有的.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-01 0:11 

注册: 2009-06-08 21:32
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
wangdu2002 写道:
先whereis瞧下tomcat的可执行文件在哪,可能在/usr/bin下也难说。。。 :em06

tomcat在这里--
/.
/var
/var/log
/var/log/tomcat6
/var/lib
/var/lib/tomcat6
/var/lib/tomcat6/webapps
/var/cache
/var/cache/tomcat6
/etc
/etc/tomcat6
/etc/tomcat6/Catalina
/etc/tomcat6/Catalina/localhost
/etc/tomcat6/catalina.properties
/etc/tomcat6/logging.properties
/etc/tomcat6/context.xml
/etc/tomcat6/server.xml
/etc/tomcat6/tomcat-users.xml
/etc/tomcat6/web.xml
/etc/tomcat6/policy.d
/etc/tomcat6/policy.d/01system.policy
/etc/tomcat6/policy.d/02debian.policy
/etc/tomcat6/policy.d/03catalina.policy
/etc/tomcat6/policy.d/04webapps.policy
/etc/tomcat6/policy.d/50local.policy
/etc/default
/etc/default/tomcat6
/etc/init.d
/etc/init.d/tomcat6
/etc/cron.daily
/etc/cron.daily/tomcat6
/usr
/usr/share
/usr/share/doc
/usr/share/doc/tomcat6
/usr/share/doc/tomcat6/copyright
/usr/share/doc/tomcat6/changelog.Debian.gz
/usr/share/tomcat6
/usr/share/tomcat6/webapps
/usr/share/tomcat6/webapps/default_root
/usr/share/tomcat6/webapps/default_root/META-INF
/usr/share/tomcat6/webapps/default_root/META-INF/context.xml
/usr/share/tomcat6/webapps/default_root/index.html
/var/lib/tomcat6/logs
/var/lib/tomcat6/work
/var/lib/tomcat6/conf


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-01 0:21 

注册: 2009-06-08 21:32
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
$ whereis tomcat6
tomcat6: /etc/tomcat6 /usr/share/tomcat6
这两个目录都试过了。不行。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-03 20:39 

注册: 2007-05-12 9:23
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
xmsroy 写道:
我用的是ubuntu9.10新立得里的tomcat和eclipse.在eclipse-->Window-->Preferences-->Server Runtime environments 下配置tomcat6时
Tomcat installation directory设为/usr/share/tomcat6时报错“ The Tomcat installation directory is not valid. It is missing expected file or folder conf.”
Tomcat installation directory设为/usr/share/tomcat6/bin时或"/usr/share/tomcat6/bin"时报错" The Tomcat installation directory is not valid. It is missing expected file or folder lib/jasper-el.jar."
希望有配置成功的朋友给个详细的解决办法。最好有出错的原因..

新立得安装的tomcat6文件分布在不同目录下面 lib和配置文件和log文件等等都不在一起,所以eclipse提示找不到文件
解决办法是自己到apache官网下个tomcat下来就可以了 ,


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-03 20:42 

注册: 2007-08-02 20:29
帖子: 21288
系统: 窓辺とうこ
送出感谢: 0 次
接收感谢: 22
建议去官方下解压就能用的那种,不要源里安装的


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu9.10下tomcat和eclipse问题
帖子发表于 : 2009-11-29 22:06 

注册: 2009-03-22 11:10
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
楼上正解,自己去下个zip包,解压缩就能用!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译