当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问进行OpenGL开发需要安装哪些软件包?
帖子发表于 : 2010-01-16 12:24 

注册: 2008-09-05 23:13
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
RT

我查到要安装下列软件包
libgl1-mesa
libgl1-mesa-dev
libglu1-mesa

glutg3
glutg3-dev
libglui-dev
libglut3
libglut3-dev

运行 sudo aptitude install libgl1-mesa libgl1-mesa-dev libglu1-mesa 之后提示
引用:
下列软件包是“破损”的:
libxcb-xlib0-dev libxcb1-dev
下列新软件包将被自动安装:
libpthread-stubs0 libpthread-stubs0-dev libx11-dev libxau-dev
libxdmcp-dev mesa-common-dev x11proto-core-dev x11proto-input-dev
x11proto-kb-dev xtrans-dev
下列“新”软件包将被安装。
libgl1-mesa-dev libpthread-stubs0 libpthread-stubs0-dev libx11-dev
libxau-dev libxdmcp-dev mesa-common-dev x11proto-core-dev
x11proto-input-dev x11proto-kb-dev xtrans-dev
0 个软件包被升级,新安装13 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 2224kB 的存档。 解包后将要使用 6910kB。
下列软件包存在未满足的依赖关系:
libxcb-xlib0-dev: 依赖: libxcb-xlib0 (= 1.1-1ubuntu1) 但是 1.1-1ubuntu1.1 已安装
libxcb1-dev: 依赖: libxcb1 (= 1.1-1ubuntu1) 但是 1.1-1ubuntu1.1 已安装
Resolving dependencies...
下列动作将解决这些依赖关系:

降级 下列软件包:
libxcb-xlib0 [1.1-1ubuntu1.1 (now) -> 1.1-1ubuntu1 (hardy, hardy)]
libxcb1 [1.1-1ubuntu1.1 (now) -> 1.1-1ubuntu1 (hardy, hardy)]

分数是 110

是否接受该解决方案?[Y/n/q/?]



是否正确?
系统版本8.04,用163的源


最后由 BBT4XD 编辑于 2010-01-16 15:03,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请问进行OpenGL开发需要安装哪些软件包?
帖子发表于 : 2010-01-16 12:28 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
换源。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译