如何降低gcc的版本

C、C++和Java语言
回复
头像
Rinick
帖子: 72
注册时间: 2006-02-18 17:47
送出感谢: 0
接收感谢: 0

如何降低gcc的版本

#1

帖子 Rinick » 2006-09-25 21:07

原来的是用build essential。gcc是4.0的

现在编译一些东西出了问题,想降低到3.3试试看

但是不知道怎么作。新立德里装了3.3也没用
xphenix
帖子: 35
注册时间: 2006-05-04 15:52
送出感谢: 0
接收感谢: 0

#2

帖子 xphenix » 2006-09-26 14:56

自己编译一个GCC3到一个独立的目录,如/usr/local/gcc3,然后把gcc和g++链接到/usr/bin下改名为 gcc3 g++3,然后把自己编译的GCC的lib目录的绝对路径写入/etc/ld.so.conf,最后sudo ldconfig。

以后编译软件时如果想用gcc3的话 在./configure 后面加入 CC=gcc3 或 CXX=g++3就可以了。

我原来用FC5的时候就是这样做的。
rhhsun
帖子: 63
注册时间: 2006-09-18 23:14
送出感谢: 0
接收感谢: 0

#3

帖子 rhhsun » 2006-09-29 22:46

试试

代码: 全选

export CC=gcc-3.3
./configure
make
头像
ubuntu_amateur
帖子: 79
注册时间: 2006-06-10 14:58
来自: China
送出感谢: 0
接收感谢: 0

#4

帖子 ubuntu_amateur » 2006-10-04 12:08

回复

回到 “C/C++/Java”