当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : error: stdio.h: No such file or directory?
帖子发表于 : 2006-09-28 10:40 

注册: 2006-08-23 12:16
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
为什么一个 最简单的程序编译 都 出错


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-09-28 12:26 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
编译环境没有设置好

代码:
sudo apt-get install build-essential


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-09-28 13:16 

注册: 2006-08-23 12:16
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
Thanks


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-27 23:40 

注册: 2007-02-09 0:14
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我也遇到这个问题:
1.build-essential
romeo@romeo-laptop:~$ sudo apt-get install build-essential
build-essential: Depends: libc6-dev but it is not going to be installedor
libc-dev
Depends: g++ (>= 4:4.0) but it is not going to be installed
E: Broken packages

2.install libc6-dev

The following packages have unmet dependencies.
libc6-dev: Depends: libc6 (= 2.3.6-0ubuntu20.4) but 2.4-1ubuntu12 is to be installed
E: Broken packages

libC6版本高了...如何是好,可以强制安装吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-31 0:41 

注册: 2006-04-19 13:36
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我已经
sudo apt-get install build-essential
可是编译的时候,还是出现找不到
stdio.h: No such file or directory
请问怎么安装.


页首
 用户资料  
 
6 楼 
 文章标题 : 高手救救我们吧 我也遇到这个问题 ,刚开始学习c语言!
帖子发表于 : 2007-04-04 17:31 

注册: 2007-04-03 18:45
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
[code][/code]


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-04 22:45 

注册: 2007-04-03 18:45
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install libc6-dev


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-04 22:47 

注册: 2007-04-03 18:45
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
要是不行 那就看看which gcc 要是没有设置环境变量那就set path 就好了 !!!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-04-15 14:04 

注册: 2008-04-15 8:08
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
root@jinqiu-desktop:/# sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包
root@jinqiu-desktop:/# sudo apt-get install libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.6.1-1ubuntu10 正要被安装
E: 无法安装的软件包


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-04-15 14:05 

注册: 2008-04-15 8:08
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
怎么回事?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-15 14:15 
头像

注册: 2007-08-11 20:54
帖子: 777
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
你要安装G++编译器啊,或者你重启一次
又或者重新更新新的软件冤列表啊
代码:
sudo apt-get update


_________________
人的生命是有限的,但是享受Linux的乐趣是无限的!
http://www.liangsuilong.info


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-15 14:37 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
AutumnKind 写道:
怎么回事?


先把你的源设好!!!!!

http://wiki.ubuntu.org.cn/Qref


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译