当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]无法安装g++编译器,请各位前辈帮忙!!
帖子发表于 : 2006-11-19 16:51 

注册: 2006-11-11 16:39
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install g++

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包
*****************************************
安装提示不能满足的依赖关系
我便试着手动安装所需依赖包,但每次都提示不能满足的XXX依赖关系,
但直到安装libc6时却说已经是最新的了。

为此感很困惑,来向各位求助,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : 另外的问题
帖子发表于 : 2006-11-19 17:16 

注册: 2006-11-11 16:39
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
gcc编译也有问题

vim helloworld.c

#include <stdio.h>
int main()
{
printf("Hello world!");
return 0;
}

gcc helloworld.c

helloworld.c:1:19: error: stdio.h: No such file or directory
helloworld.c: In function ‘main’:
helloworld.c:4: warning: incompatible implicit declaration of built-in function ‘printf’


好像是没有头文件?这是怎么回啊,libc6已经是最新的了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-20 16:49 
头像

注册: 2006-11-15 14:28
帖子: 67
地址: Beijing
送出感谢: 0 次
接收感谢: 3
sudo apt-get install gcc g++ libgcc1 libg++ make gdb


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-20 21:59 

注册: 2006-11-11 16:39
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
还是不行,老样子啊


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-21 11:09 
头像

注册: 2006-11-15 14:28
帖子: 67
地址: Beijing
送出感谢: 0 次
接收感谢: 3
wybno1 写道:
还是不行,老样子啊


你确定我说的那几个安装是成功的?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-21 11:21 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
sudo apt-get install build-essential


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-21 13:24 

注册: 2006-11-11 16:39
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install build-essential

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-21 13:27 

注册: 2006-11-11 16:39
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
volans 写道:
wybno1 写道:
还是不行,老样子啊


你确定我说的那几个安装是成功的?


sudo apt-get install gcc g++ libgcc1 libg++ make gdb

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
gcc 已经是最新的版本了。
libgcc1 已经是最新的版本了。
注意,我选了 libg++2.8.1.3-glibc2.2 而非 libg++
make 已经是最新的版本了。
gdb 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.0 (>= 4.0.3) 但是它将不会被安装
E: 无法安装的软件包

先谢谢大家了!可是试了,还是不行。总是无法满足依赖关系。。。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-21 13:58 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
源换过没有?尽量用官方源。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译