JDK版本都是向下兼容的吗?

C、C++和Java语言
回复
dengyongbin0121
帖子: 6
注册时间: 2006-11-24 21:16
送出感谢: 0
接收感谢: 0
联系:

JDK版本都是向下兼容的吗?

#1

帖子 dengyongbin0121 » 2006-11-24 21:36

是不是所有的新版都能兼容旧版:

更直接点吧:我打开一个网页的时候它要求我安装JDK1.4,请问我如果安装1.5的话可以用吗?
QQ13091050
MSN:dengyongbin@live.com
mystlynx
帖子: 71
注册时间: 2006-10-28 8:19
送出感谢: 0
接收感谢: 0

#2

帖子 mystlynx » 2006-11-25 0:18

基本上是向下兼容的,看看网页的话更不用担心。

极个别的情况下,有些老的java程序只兼容Microsoft Java虚拟机,比如极个别的地图网站。
dengyongbin0121
帖子: 6
注册时间: 2006-11-24 21:16
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 dengyongbin0121 » 2006-11-25 17:24

我公司Oracle 11i ERP要JDK1.4.2_04,我装上去后中文字体不能显示,后来我换成jre1.5.0.6,结果找都打不开了。

但是网上地图可以找开(一样不能显示中文)

看来只能用1.42的了。但我花了两天的时间也没有搞定中文显示的问题。救我呀。
lgn21st
帖子: 30
注册时间: 2006-06-09 17:33
送出感谢: 0
接收感谢: 0

#4

帖子 lgn21st » 2007-02-21 23:52

呵呵,jdk1.2+和jdk1.1不大兼容哦,跨越时代的版本
头像
ggjjzhzz
帖子: 137
注册时间: 2006-12-21 9:46
送出感谢: 0
接收感谢: 0

#5

帖子 ggjjzhzz » 2007-02-25 17:02

JDK1.4和1.5差别很大,要完全兼容是不太可能的。装两个JDK版本也不错。
头像
iridiumcao
帖子: 245
注册时间: 2007-01-18 18:05
来自: Shanghai
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 iridiumcao » 2007-03-17 18:10

不是完全兼容的。不同公司的JDK的情况我不清楚。

但我一直使用SUN的JDK,1.6就有不兼容1.5的地方,比如for-each循环。

可以参看这个帖子:
http://www.chinajavaworld.com/thread.js ... dID=731892
Dell Inspiron 1501
Xubuntu&Lubuntu 11.10

Ade, Gnome3, Ade, Unity!

随心所欲不逾矩
回复

回到 “C/C++/Java”