安装gcc时出错(MD5 校验和不符),无法使用make命令,无法用gcc编译,找不到能正确安装gcc

C、C++和Java语言
回复
oranggge
帖子: 5
注册时间: 2006-12-09 1:22
送出感谢: 0
接收感谢: 0

安装gcc时出错(MD5 校验和不符),无法使用make命令,无法用gcc编译,找不到能正确安装gcc

#1

帖子 oranggge » 2006-12-10 18:23

ubuntu版本:6.0.6.1 LTS \n\1
ISO: ubuntu-6.06-alternate-i386.iso

安装GCC时出现如下情况:
sudo apt-get install gcc g++ libgcc1 libg++ make gdb
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
gcc 已经是最新的版本了。
libgcc1 已经是最新的版本了。
注意,我选了 libg++2.8.1.3-glibc2.2 而非 libg++
gdb 已经是最新的版本了。
将会安装下列额外的软件包:
g++-4.0 libc6-dev libg++2.8.1.3-glibc2.2 libstdc++2.10-glibc2.2
libstdc++6-4.0-dev linux-kernel-headers
建议安装的软件包:
lib64stdc++6 glibc-doc manpages-dev libstdc++6-4.0-doc stl-manual
下列【新】软件包将被安装:
g++ g++-4.0 libc6-dev libg++2.8.1.3-glibc2.2 libstdc++2.10-glibc2.2
libstdc++6-4.0-dev linux-kernel-headers make
共升级了 0 个软件包,新安装了 8 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/8535kB 的软件包。
解压缩后会消耗掉 35.9MB 的额外空间。
您希望继续执行吗?[Y/n]y
更换介质:请把标有
“Ubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)”
的碟片插入驱动器“/cdrom/”再按回车键

无法下载 cdrom:[Ubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)]/pool/main/l/linux-kernel-headers/linux-kernel-headers_2.6.11.2-0ubuntu18_i386.deb MD5 校 验和不符
无法下载 cdrom:[Ubuntu 6.06 _Dapper Drake_ - Release i386 (20060531)]/pool/main/m/make/make_3.80+3.81.b4-1_i386.deb MD5 校验和不符
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?

使用GCC命令时出现如下情况:
gcc -o hello helloworld.cpp
gcc: installation problem, cannot exec 'cc1plus': No such file or directory

使用make命令时出现如下情况:
make
bash: make: command not found

使用更新命令时找不到可用更新,也试过用其它命令安装GCC,几乎wiki上所能找到的都试过,情况同上。
我该怎么办呢?谢谢
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2006-12-10 19:31

换源
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
oranggge
帖子: 5
注册时间: 2006-12-09 1:22
送出感谢: 0
接收感谢: 0

#3

帖子 oranggge » 2006-12-10 20:54

升级到6.10版不知道可不可以,实在不行就只好试下了。
oranggge
帖子: 5
注册时间: 2006-12-09 1:22
送出感谢: 0
接收感谢: 0

#4

帖子 oranggge » 2006-12-29 23:24

用新产得装了些gcc的相关软件包后,问题得到解决,具体装了哪些,已经忘了。
回复

回到 “C/C++/Java”