vim中无高亮且不能使用:syntax on命令

C、C++和Java语言
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

vim中无高亮且不能使用:syntax on命令

#1

帖子 zhwalker » 2006-12-26 19:15

不知道为什么,vim中没有语法高亮了,而且:syntax on/:syntax enable语句得到信息:
Error detected while processing /usr/share/vim/vim70/syntax/syntax.vim:
line 42:
E216: No such group or event: filetypedetect BufRead
syntax.vim文件的内容如下:
" Vim syntax support file
" Maintainer: Bram Moolenaar <Bram@vim.org>
" Last Change: 2001 Sep 04

" This file is used for ":syntax on".
" It installs the autocommands and starts highlighting for all buffers.

if !has("syntax")
finish
endif

" If Syntax highlighting appears to be on already, turn it off first, so that
" any leftovers are cleared.
if exists("syntax_on") || exists("syntax_manual")
so <sfile>:p:h/nosyntax.vim
endif

" Load the Syntax autocommands and set the default methods for highlighting.
runtime syntax/synload.vim

" Load the FileType autocommands if not done yet.
if exists("did_load_filetypes")
let s:did_ft = 1
else
filetype on
let s:did_ft = 0
endif

" Set up the connection between FileType and Syntax autocommands.
" This makes the syntax automatically set when the file type is detected.
augroup syntaxset
au! FileType * exe "set syntax=" . expand("<amatch>")
augroup END


" Execute the syntax autocommands for the each buffer.
" If the filetype wasn't detected yet, do that now.
" Always do the syntaxset autocommands, for buffers where the 'filetype'
" already was set manually (e.g., help buffers).
doautoall syntaxset FileType
if !s:did_ft
doautoall filetypedetect BufRead
endif
请问高手这是怎么回事阿?怎么能够解决这个问题阿?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-12-26 19:29

版本呢
● 鸣学
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#3

帖子 zhwalker » 2006-12-26 19:34

版本是VIM - Vi IMproved 7.0 (2006 May 7, compiled May 12 2006 08:03:48)
Included patches: 1-10
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-12-26 20:01

sudo apt-get install vim-gtk


edgy里面的默认的vim只是个tiny版本,啥功能没有.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
kelvinhan
帖子: 173
注册时间: 2006-11-30 1:29
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 kelvinhan » 2006-12-26 22:14

sudo apt-get install vim-full
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#6

帖子 zhwalker » 2006-12-26 22:42

Vim-gtk还是不行。。。。
Vim-full还在尝试中,不知道行不行。。。。。
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#7

帖子 zhwalker » 2006-12-26 23:07

vim-full还是不行
我的VIm本来是有高亮的,但是今天不知道设置什么的时候可能给改了什么设置就变成这样了
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2006-12-27 0:07

是vim-gnome。

$● as vim|grep ^i
i vim-common - Vi IMproved - Common files
i vim-gnome - Vi IMproved - enhanced vi editor - with GN
i A vim-gui-common - Vi IMproved - Common GUI files
i A vim-runtime - Vi IMproved - Runtime files
i vim-tiny - Vi IMproved - enhanced vi editor - compact
● 鸣学
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#9

帖子 zhwalker » 2006-12-27 8:38

对不起,但是看不懂啊。
能不能把命令写的详细点阿,我还是大菜鸟。。。。。。
dreamagain
帖子: 17
注册时间: 2006-08-09 15:03
送出感谢: 0
接收感谢: 0

#10

帖子 dreamagain » 2006-12-27 11:21

apt-get install vim*
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#11

帖子 zhwalker » 2006-12-27 13:34

The following packages have unmet dependencies.
amavis-ng: Conflicts: amavis
amavisd-new: Conflicts: amavis
dvi2ps-fontdesc-morisawa5: Depends: vfdata-morisawa5 but it is not going to be installed
elvis: Conflicts: elvis-console but 2.2.0-5 is to be installed
elvis-console: Conflicts: elvis but 2.2.0-5 is to be installed
evince-gtk: Conflicts: evince but 0.5.2-0ubuntu3.2 is to be installed
libcvsservice-dev: Depends: kdelibs4-dev (>= 4:3.5.0) but it is not going to be installed
libgtk2-ex-podviewer-perl: Conflicts: libgtk2-podviewer-perl but 0.09-2 is to be installed
monodoc-gtksourceview2.0-manual: Conflicts: monodoc-gtksourceview-manual but 0.5-7 is to be installed
nvidia-glx: Conflicts: nvidia-settings but 1.0-3ubuntu7 is to be installed
Conflicts: nvidia-xconfig but 1.0+20051122-2 is to be installed
nvidia-glx-legacy: Conflicts: nvidia-glx
nvidia-glx-legacy-dev: Conflicts: nvidia-glx-dev but 1.0.8776+2.6.15.12-1 is to be installed
nvidia-legacy-kernel-source: Conflicts: nvidia-kernel-source
E: Broken packages
zhwalker
帖子: 10
注册时间: 2006-12-24 18:41
送出感谢: 0
接收感谢: 0

#12

帖子 zhwalker » 2006-12-27 13:36

还是不行阿。。。。
能不能把vim删除掉,重新装一遍vim?
头像
yatusiter
帖子: 33
注册时间: 2006-07-28 9:16
来自: 福建 XMU
送出感谢: 0
接收感谢: 0

#13

帖子 yatusiter » 2007-01-01 1:55

我用的是
sudo apt-get install vim 然后就可以拉。。。
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 lisir » 2007-01-03 10:28

楼主试试在家目录下建立一个.vimrc的文件:

代码: 全选

touch .vimrc
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
liujin
帖子: 19
注册时间: 2007-01-04 13:38
送出感谢: 0
接收感谢: 0

#15

帖子 liujin » 2007-01-05 21:46

在wiki里说修改主目录里的 .vimrc文件,在下面加上syntax on就可以了
但我在我的主目录里找不到这个文件,只找到了一个叫 .viminfo 的文件。
不过我的在vim里输入:syn on命令就能打开高亮了
只是麻烦了点
(第一次在这个论坛里发帖,不足之处,大家体谅)
忘了说了,我的版本是6.10
回复

回到 “C/C++/Java”