[问题]eclipse 无法使用(尚为解决)

C、C++和Java语言
jasonding
帖子: 46
注册时间: 2006-09-30 22:54
送出感谢: 0
接收感谢: 0
联系:

[问题]eclipse 无法使用(尚为解决)

#1

帖子 jasonding » 2007-01-18 22:49

[配置 Eclipse]
sudo apt-get install eclipse
将 SUN Java 完完全全的设置为系统的默认 JDK:
sudo update-java-alternatives -s java-1.5.0-sun
编辑 JVM 配置文件:
sudo gedit /etc/jvm
将文件中的
/usr/lib/jvm/java-1.5.0-sun
这一行移动到配置块的顶部。
编辑 Eclipse 的 java_home 文件:
sudo gedit /etc/eclipse/java_home
将文件中的
/usr/lib/jvm/java-1.5.0-sun
这一行移动到文件的顶部。

这是我从论坛里看到的安装步骤,照做了,可是上面提到到/etc/eclipse/java_home中并没有找到/usr/lib/jvm/java-1.5.0-sun一项,而且启动eclipse时提示“the custom VM you have chosen is not a valid executable”
请问是什么问题?怎么解决?谢谢!!
上次由 jasonding 在 2007-01-19 11:43,总共编辑 1 次。
头像
oneleaf
论坛管理员
帖子: 10226
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2007-01-18 23:07

在 /etc/eclipse/java_home 手工输入/usr/lib/jvm/java-1.5.0-sun。
jasonding
帖子: 46
注册时间: 2006-09-30 22:54
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jasonding » 2007-01-19 11:42

我试过了,依然不行。请问还有其他办法吗?
winstars
帖子: 131
注册时间: 2006-09-07 16:02
送出感谢: 0
接收感谢: 0

#4

帖子 winstars » 2007-02-05 12:58

卸掉系统的eclipse,自己去官方下回来eclipse for linux相应版本,另外,卸掉gcj,还不成熟
warmwind
帖子: 3
注册时间: 2007-03-12 10:44
送出感谢: 0
接收感谢: 0

#5

帖子 warmwind » 2007-04-02 17:54

我的也是一样,请问现在lz解决了嘛?
CHILLI
帖子: 1
注册时间: 2006-08-03 17:57
送出感谢: 0
接收感谢: 0

#6

帖子 CHILLI » 2007-04-03 14:46

create a launch in the desktop like this "/usr/bin/eclipse -vm /usr/lib/j2sdk1.6-sun/bin/java"
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#7

帖子 依寻依然 » 2007-04-29 14:38

因为eclipse官方的就是解压直接用,建议用官方的好一些
头像
anticlockwise
帖子: 2393
注册时间: 2007-03-01 20:46
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 anticlockwise » 2007-04-30 17:14

源里边的eclipse不好,总是崩溃,建议去官方下载,或者去下载EasyEclipse发行版,我觉那个挺好的~~
http://www.easyeclipse.org
头像
syhan
帖子: 272
注册时间: 2006-09-06 12:24
来自: Southeast University
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 syhan » 2007-05-09 15:33

试试类似这样的启动,指定自己的jvm
/opt/eclipse/eclipse -vm /usr/lib/jvm/ibm-java2-i386-50/bin/java -vmargs -Duser.language=en -Xms128m -Xmx512m -XX:PermSize=64m -XX:MaxPermSize=128m
awesome + stalonetrayer + urxvt + rox-filer + feh + SLiM
碧海潮声
帖子: 8
注册时间: 2007-05-10 22:20
送出感谢: 0
接收感谢: 0

#10

帖子 碧海潮声 » 2007-05-23 21:05

进入eclipse目录,执行
ln -s 你的jre路径
例如:

ln -s /usr/lib/jvm/java-6-sun/jre
头像
182185953b
帖子: 24
注册时间: 2007-05-25 11:32
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 182185953b » 2007-05-28 16:57

anticlockwise 写了:源里边的eclipse不好,总是崩溃,建议去官方下载,或者去下载EasyEclipse发行版,我觉那个挺好的~~
http://www.easyeclipse.org
谁说源里的不好了,我用的就是源里的。我还把他给汉化了呢!
世事番腾似转轮,眼前凶吉未为真。
请看久久分明应,天道何曾负善人。
vbarter
帖子: 60
注册时间: 2006-11-28 18:10
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 vbarter » 2007-06-30 15:56

默认的是使用的/usr/bin/eclipse
不妨试试 /usr/lib/eclipse/eclipse
waldenlake
帖子: 28
注册时间: 2007-06-22 16:22
送出感谢: 0
接收感谢: 0

#13

帖子 waldenlake » 2007-07-04 19:14

去eclipse官方网下 解压到任何人间夹运行就好了 不要用源里面的
starster888
帖子: 98
注册时间: 2007-03-19 19:15
送出感谢: 0
接收感谢: 0

jdk 和eclipse安装好后你就别动,直接用就可以了

#14

帖子 starster888 » 2007-07-05 20:34

jdk 和eclipse安装好后你就别动,直接用就可以了
头像
czybear
帖子: 54
注册时间: 2007-06-12 17:22
送出感谢: 0
接收感谢: 0

#15

帖子 czybear » 2007-07-05 21:51

代码: 全选

which java
看看能否找到java
eclipse的配置一般是不要动的
jdk装好了要配一些环境变量的
例如,我的jdk装好后位于/usr/java/jdk1.5.0_10/
在终端执行下面两条命令,并将下面两行添加到/etc/profile

代码: 全选

export JAVA_HOME=/usr/java/java
export PATH=$JAVA_HOME/bin:$PATH
应该就没有什么问题了。
回复

回到 “C/C++/Java”