装不上build-essential,好像什么依赖关系不对,大家帮帮忙,谢谢!

C、C++和Java语言
回复
pipibug
帖子: 7
注册时间: 2005-10-14 10:56
送出感谢: 0
接收感谢: 0

装不上build-essential,好像什么依赖关系不对,大家帮帮忙,谢谢!

#1

帖子 pipibug » 2007-01-31 10:58

pipibug@pipibug:csrc$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包
pipibug
帖子: 7
注册时间: 2005-10-14 10:56
送出感谢: 0
接收感谢: 0

#2

帖子 pipibug » 2007-01-31 10:59

pipibug@pipibug:csrc$ sudo apt-get install libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20) 但是 2.3.6-0ubuntu20.1 正要被安装
E: 无法安装的软件包
pipibug
帖子: 7
注册时间: 2005-10-14 10:56
送出感谢: 0
接收感谢: 0

#3

帖子 pipibug » 2007-01-31 11:00

pipibug@pipibug:csrc$ sudo apt-cache depends libc6-dev
libc6-dev
依赖: libc6
依赖: linux-kernel-headers
建议: glibc-doc
建议: manpages-dev
|推荐: gcc
推荐: <c-compiler>
gcc272
bcc
gcc
gcc-2.95
gcc-3.3
gcc-3.4
gcc-4.0
tcc
冲突: libstdc++2.10-dev
冲突: gcc-2.95
冲突: <libpthread0-dev>
冲突: <libdl1-dev>
冲突: <libdb1-dev>
冲突: <libgdbm1-dev>
冲突: libc6-dev
冲突: locales
冲突: <libstdc++2.9-dev>
冲突: <netkit-rpc>
冲突: <libc-dev>
替换: man-db
替换: gettext
替换: ppp
替换: <libgdbmg1-dev>
替换: <ldso>
替换: <netkit-rpc>
替换: netbase
替换: kerberos4kth-dev
替换: libc6-prof
mooncake3680
帖子: 3
注册时间: 2007-03-29 11:08
送出感谢: 0
接收感谢: 0

#4

帖子 mooncake3680 » 2007-03-29 12:55

貌似还是源的问题~~~将源改为和你ubuntu版本相对应的~~
ziyun
帖子: 262
注册时间: 2007-03-29 12:59
送出感谢: 0
接收感谢: 0

#5

帖子 ziyun » 2007-03-29 17:16

删除冲突的包就好了,我试过这个办法
回复

回到 “C/C++/Java”